Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.2.1
    • Component/s: Integration - Maven 2
    • Labels:
      None
    • Environment:
      Java version: 1.5.0_12
      OS name: "linux" version: "2.6.9-42.elsmp" arch: "i386" Family: "unix"

      Description

      I'm getting this error while trying to add a new project using the upload POM option.

      Java version: 1.5.0_12
      OS name: "linux" version: "2.6.9-42.elsmp" arch: "i386" Family: "unix"

      2008-09-24 18:07:31,096 [btpool0-8] INFO interceptor#exceptionLogging - Error ocurred during execution
      org.apache.maven.continuum.ContinuumException: Error reading POM
      at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:94)
      at org.apache.maven.continuum.web.action.AddMavenProjectAction.execute(AddMavenProjectAction.java:158)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.opensymphony.xwork.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:358)
      at com.opensymphony.xwork.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:218)
      at com.opensymphony.webwork.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:35)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.io.FileNotFoundException: /tmp/Jetty_0_0_0_0_8084_continuum_continuum3c2jpt/upload1f6a6380_11c96626dce_7ff5_00000024.tmp (No such file or directory)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:106)
      at java.io.FileInputStream.<init>(FileInputStream.java:66)
      at java.io.FileReader.<init>(FileReader.java:41)
      at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:82)
      ... 9 more

        Activity

        Francisco Herrera created issue -
        Tobias Mattsson added a comment -

        We're having the exact same problem.

        JDK 1.5.0_14
        Continuum 1.2
        Standalone installation

        Stacktrace:
        org.apache.maven.continuum.ContinuumException: Error reading POM
        at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:94)
        at org.apache.maven.continuum.web.action.AddMavenProjectAction.execute(AddMavenProjectAction.java:158)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at com.opensymphony.xwork.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:358)
        at com.opensymphony.xwork.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:218)
        at com.opensymphony.webwork.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:35)
        at java.lang.Thread.run(Thread.java:595)
        Caused by: java.io.FileNotFoundException: /tmp/Jetty_0_0_0_0_8610_continuum_continuum6r2r7e/upload_4c41f9ba_11c95317849_7ff5_00000028.tmp (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:106)
        at java.io.FileInputStream.<init>(FileInputStream.java:66)
        at java.io.FileReader.<init>(FileReader.java:41)
        at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:82)
        ... 9 more

        Emmanuel Venisse added a comment -

        The user that started jetty doesn't have all write rights on /tmp

        Emmanuel Venisse made changes -
        Field Original Value New Value
        Resolution Not A Bug [ 6 ]
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Emmanuel Venisse [ evenisse ]
        Rohan Holt added a comment -

        I am getting the same problem with Continuum 1.2 Build 697023 under tomcat 5.5.27. I do have write perms on the temp directory being written to ( as it was created by tomcat ). Here is an extract from the log file:

        2008-09-25 11:24:19,481 [http-9080-Processor23] INFO com.opensymphony.webwork.interceptor.FileUploadInterceptor - File m2PomFile text/xml pom.xml /u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum/upload_4cc4acca_11c98b2e2a5__7ff5_00000095.tmp
        2008-09-25 11:24:19,535 [http-9080-Processor23] INFO com.opensymphony.webwork.interceptor.FileUploadInterceptor - Removing file m2PomFile /u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum/upload_4cc4acca_11c98b2e2a5__7ff5_00000095.tmp
        2008-09-25 11:24:22,576 [http-9080-Processor25] INFO interceptor#exceptionLogging - Error ocurred during execution
        org.apache.maven.continuum.ContinuumException: Error reading POM
        at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:94)
        at org.apache.maven.continuum.web.action.AddMavenProjectAction.execute(AddMavenProjectAction.java:158)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at com.opensymphony.xwork.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:358)
        at com.opensymphony.xwork.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:218)
        at com.opensymphony.webwork.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:35)
        at java.lang.Thread.run(Thread.java:595)
        Caused by: java.io.FileNotFoundException: /u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum/upload_4cc4acca_11c98b2e2a5__7ff5_00000095.tmp (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:106)
        at java.io.FileInputStream.<init>(FileInputStream.java:66)
        at java.io.FileReader.<init>(FileReader.java:41)
        at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:82)
        ... 9 more

        It seems the file is being removed almost as soon as it is uploaded so I selected a large (non-pom) file to see if I could see the uploaded file in the temp dir during transit..

        rw-rr- 1 root root 44 2008-09-25 09:49 tldCache.ser
        drwxr-xr-x 3 root root 72 2008-09-25 09:52 org
        rw-rr- 1 root root 4 2008-09-25 12:03 upload_4cc4acca_11c98b2e2a5__7ff5_00000122.tmp
        rw-rr- 1 root root 822442 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000123.tmp
        jupiter:/u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum # ls -ltr
        total 16
        rw-rr- 1 root root 44 2008-09-25 09:49 tldCache.ser
        drwxr-xr-x 3 root root 72 2008-09-25 09:52 org
        rw-rr- 1 root root 4 2008-09-25 12:03 upload_4cc4acca_11c98b2e2a5__7ff5_00000122.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000125.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000124.tmp
        jupiter:/u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum # ls -ltr
        total 16
        rw-rr- 1 root root 44 2008-09-25 09:49 tldCache.ser
        drwxr-xr-x 3 root root 72 2008-09-25 09:52 org
        rw-rr- 1 root root 4 2008-09-25 12:03 upload_4cc4acca_11c98b2e2a5__7ff5_00000122.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000125.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000124.tmp
        jupiter:/u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum # ls -ltr
        total 16
        rw-rr- 1 root root 44 2008-09-25 09:49 tldCache.ser
        drwxr-xr-x 3 root root 72 2008-09-25 09:52 org
        rw-rr- 1 root root 4 2008-09-25 12:03 upload_4cc4acca_11c98b2e2a5__7ff5_00000122.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000125.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000124.tmp
        jupiter:/u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum # ls -ltr
        total 16
        rw-rr- 1 root root 44 2008-09-25 09:49 tldCache.ser
        drwxr-xr-x 3 root root 72 2008-09-25 09:52 org
        rw-rr- 1 root root 4 2008-09-25 12:03 upload_4cc4acca_11c98b2e2a5__7ff5_00000122.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000125.tmp
        rw-rr- 1 root root 1 2008-09-25 12:04 upload_4cc4acca_11c98b2e2a5__7ff5_00000124.tmp
        jupiter:/u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum # ls -ltr
        total 4
        rw-rr- 1 root root 44 2008-09-25 09:49 tldCache.ser
        drwxr-xr-x 3 root root 72 2008-09-25 09:52 org
        jupiter:/u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum #

        ---- continuum.log Extract —
        2008-09-25 12:03:53,700 [http-9080-Processor25] INFO com.opensymphony.webwork.dispatcher.DispatcherUtils - Unable to find 'webwork.multipart.saveDir' property setting. Defaulting to javax.servlet.context.tempdir
        2008-09-25 12:04:38,080 [http-9080-Processor25] INFO com.opensymphony.webwork.interceptor.FileUploadInterceptor - File m2PomFile application/octet-stream DatabaseInstallChangeset.bundle /u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum/upload_4cc4acca_11c98b2e2a5__7ff5_00000123.tmp
        2008-09-25 12:04:38,092 [http-9080-Processor25] INFO com.opensymphony.webwork.interceptor.FileUploadInterceptor - Removing file m2PomFile /u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum/upload_4cc4acca_11c98b2e2a5__7ff5_00000123.tmp
        2008-09-25 12:04:40,492 [http-9080-Processor23] INFO interceptor#exceptionLogging - Error ocurred during execution
        org.apache.maven.continuum.ContinuumException: Error reading POM
        at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:94)
        at org.apache.maven.continuum.web.action.AddMavenProjectAction.execute(AddMavenProjectAction.java:158)
        at sun.reflect.GeneratedMethodAccessor181.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at com.opensymphony.xwork.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:358)
        at com.opensymphony.xwork.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:218)
        at com.opensymphony.webwork.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:35)
        at java.lang.Thread.run(Thread.java:595)
        Caused by: java.io.FileNotFoundException: /u01/app/tomcat/apache-tomcat-5.5.27/work/Catalina/localhost/continuum/upload_4cc4acca_11c98b2e2a5__7ff5_00000123.tmp (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:106)
        at java.io.FileInputStream.<init>(FileInputStream.java:66)
        at java.io.FileReader.<init>(FileReader.java:41)
        at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:82)
        ... 8 more

        This clearly shows that during the upload..the file (upload_4cc4acca_11c98b2e2a5__7ff5_00000123.tmp) was being created in the correct directory but was subsequently removed before being able to be processed.

        Would you please consider reopening this issue...

        Emmanuel Venisse added a comment -

        Reopen the issue due to new informations

        Emmanuel Venisse made changes -
        Status Closed [ 6 ] Reopened [ 4 ]
        Assignee Emmanuel Venisse [ evenisse ]
        Resolution Not A Bug [ 6 ]
        Emmanuel Venisse made changes -
        Fix Version/s 1.2.1 [ 14539 ]
        Olivier Lamy (*$^¨%`£) added a comment -

        IMHO, the file is removed by the fileUploadInterceptor before the project is added.
        To fix this we can copy the uploaded file in java.io.tmpdir to use it in continuum.
        WDYT ?

        Emmanuel Venisse added a comment -

        It can be a solution

        Olivier Lamy (*$^¨%`£) added a comment -

        It looks there is some issues using the interceptor "execAndWait" and the fileUploadInterceptor.

        Olivier Lamy (*$^¨%`£) added a comment -

        I have added a small in the execWait interceptor. During this time the file can be copy to a tmp one before the fileUpload interceptor remove the real one.
        rev 700273 in 1.2.x branch (merge in trunk rev 700274).
        If it's not enough please reopen the issue.

        Olivier Lamy (*$^¨%`£) made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Assignee Olivier Lamy [ olamy ]
        Senthil added a comment -

        How to get the fixed version of the continuum jars. Can anybody helpme to get the latest version.
        I want this fix.

        Olivier Lamy (*$^¨%`£) added a comment -
        svn co https://svn.apache.org/repos/asf/continuum/branches/continuum-1.2.x/ && cd continuum-1.2.x && mvn clean install -DskipTests
        

        And you have all builds.

        Senthil added a comment -

        thanks Olivier.

        Stefan Lecho added a comment -

        Starting this version results in an error: "Unable to compile class for JSP"

        Stacktrace:
        281172 [WrapperSimpleAppMain] INFO org.mortbay.log - Started SelectChannelConnector@0.0.0.0:8080
        java.lang.IllegalArgumentException
        at sun.net.www.ParseUtil.decode(Unknown Source)
        at sun.misc.URLClassPath$FileLoader.<init>(Unknown Source)
        at sun.misc.URLClassPath$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.misc.URLClassPath.getLoader(Unknown Source)
        at sun.misc.URLClassPath.getLoader(Unknown Source)
        at sun.misc.URLClassPath.findResource(Unknown Source)
        at java.net.URLClassLoader$2.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findResource(Unknown Source)
        at org.apache.jasper.servlet.JasperLoader.getResourceAsStream(JasperLoader.java:145)
        at org.apache.jasper.compiler.JDTCompiler$1.findType(JDTCompiler.java:184)
        at org.apache.jasper.compiler.JDTCompiler$1.findType(JDTCompiler.java:169)
        at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.createPackage(LookupEnvironment.java:517)
        at org.eclipse.jdt.internal.compiler.lookup.CompilationUnitScope.buildTypeBindings(CompilationUnitScope.java:83)
        at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.buildTypeBindings(LookupEnvironment.java:144)
        at org.eclipse.jdt.internal.compiler.Compiler.beginToCompile(Compiler.java:292)
        at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:315)
        at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:399)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:297)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:276)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:264)
        at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:563)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:303)
        at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
        at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
        at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
        at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
        at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
        at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
        at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:285)
        at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:126)
        at org.mortbay.jetty.servlet.DefaultServlet.doGet(DefaultServlet.java:463)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1097)
        at com.opensymphony.webwork.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:189)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1088)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1088)
        at com.opensymphony.webwork.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:88)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1088)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
        at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
        at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
        at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
        at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
        at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
        at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
        at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
        at org.mortbay.jetty.Server.handle(Server.java:324)
        at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
        at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
        at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:513)
        at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
        at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
        at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
        at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
        java.lang.IllegalArgumentException
        at sun.net.www.ParseUtil.decode(Unknown Source)
        at sun.misc.URLClassPath$FileLoader.<init>(Unknown Source)
        at sun.misc.URLClassPath$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.misc.URLClassPath.getLoader(Unknown Source)
        at sun.misc.URLClassPath.getLoader(Unknown Source)
        at sun.misc.URLClassPath.findResource(Unknown Source)
        at java.net.URLClassLoader$2.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findResource(Unknown Source)
        at org.apache.jasper.servlet.JasperLoader.getResourceAsStream(JasperLoader.java:145)
        at org.apache.jasper.compiler.JDTCompiler$1.findType(JDTCompiler.java:184)
        at org.apache.jasper.compiler.JDTCompiler$1.findType(JDTCompiler.java:169)
        at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.createPackage(LookupEnvironment.java:517)
        at org.eclipse.jdt.internal.compiler.lookup.CompilationUnitScope.buildTypeBindings(CompilationUnitScope.java:83)
        at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.buildTypeBindings(LookupEnvironment.java:144)
        at org.eclipse.jdt.internal.compiler.Compiler.beginToCompile(Compiler.java:292)
        at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:315)
        at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:399)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:297)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:276)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:264)
        at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:563)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:303)
        at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
        at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
        at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
        at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
        at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
        at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
        at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:285)
        at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:126)
        at org.mortbay.jetty.servlet.DefaultServlet.doGet(DefaultServlet.java:463)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1097)
        at com.opensymphony.webwork.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:189)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1088)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1088)
        at com.opensymphony.webwork.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:88)
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1088)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
        at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
        at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
        at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
        at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
        at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
        at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
        at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
        at org.mortbay.jetty.Server.handle(Server.java:324)
        at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
        at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
        at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:513)
        at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
        at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
        at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
        at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
        307687 [btpool0-8] WARN org.mortbay.log - /continuum/
        org.apache.jasper.JasperException: Unable to compile class for JSP
        at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:572)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:303)

        Olivier Lamy (*$^¨%`£) added a comment -

        fixed (build continuum from the branch/trunk or wait next build in vmbuild ).

        Stefan Lecho added a comment -

        Yesterday I was able to download the build available on vmbuild, but today I'm receiving an Authorisation Error: "You are not authorized to access this page. Please contact your administrator to be granted the appropriate permissions. ".

        Brett Porter added a comment -

        fixed

        Mark Thomas made changes -
        Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
        Mark Thomas made changes -
        Workflow jira [ 12710550 ] Default workflow, editable Closed status [ 12740292 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
        Mark Thomas made changes -
        Workflow jira [ 12947767 ] Default workflow, editable Closed status [ 12983195 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        3h 50m 1 Emmanuel Venisse 25/Sep/08 04:26
        Closed Closed Reopened Reopened
        3h 32m 1 Emmanuel Venisse 25/Sep/08 07:59
        Reopened Reopened Closed Closed
        4d 9h 59m 1 Olivier Lamy (*$^¨%`£) 29/Sep/08 17:59

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Francisco Herrera
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development