Uploaded image for project: 'Continuum'
  1. Continuum
  2. CONTINUUM-1742

Duplicate installations (environment variables) in Profile are accepted

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.2
    • Component/s: Core - Profiles
    • Labels:
      None
    • Environment:
      WinXP
    • Flags:
      Patch

      Description

      This is only encountered when adding installation of type Environment Variable.

      1. Click Profiles from the left navigation menu
      2. Click Add button
      3. Input Profile Name and click Save
      4. Select an Installation Name from the drop down list and click add. In my case I only have one installation which is java.
      5. Repeat step five(4) twice, using the same installation name.

      Result: 3 installations with the same name were added to the profile.

      6. Delete one of the installation by clicking the Delete icon.

      Result: All 3 installations with the same name were deleted.

        Activity

        olamy Olivier Lamy (*$^¨%`£) added a comment -

        I cannot reproduce it.
        Someone else can ?

        wsmoak Wendy Smoak added a comment -

        I can add duplicate environment variables to a profile (but not duplicate JDK's.) See attached continuum-duplicate-envar.png .

        Not sure yet about the deletions.

        olamy Olivier Lamy (*$^¨%`£) added a comment -

        fixed in rev 655380
        Attached patch not used.


          People

          • Assignee:
            olamy Olivier Lamy (*$^¨%`£)
            Reporter:
            jzurbano jzurbano
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development