Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1-beta-4
    • Fix Version/s: 1.2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 2004 server installation

      Description

      I have three Continuum instances running now and for one of them there seems to be some state issue when attempting to add a module to a project group. There is no problem adding modules to the other two instances.

      When invoking this operation I get a NullPointerException (see the attachment).

      1. stacktrace.txt
        8 kB
        Kevin Christmas

        Activity

        Kevin Christmas created issue -
        Kevin Christmas made changes -
        Field Original Value New Value
        Attachment stacktrace.txt [ 30576 ]
        Kevin Christmas added a comment -

        I cloned CONTINUUM-1265 which seems to be the same issue. I am currently using 1.1-beta-4 however.

        This issue has been driving me crazy for the last few days, but I think I've been able to figure out how to recreate it.

        It problem manifests itself when you initially add a multi-module pom.xml file. After all main project and sub projects (inherits from parent) loads, I add a notifications section to the parent pom.xml and commit it to subversion. Continuum is unable to deal the added notifications section and neither the parent project or child projects can be saved.

        Emmanuel Venisse added a comment -

        Can you explain how to reproduce this issue? I tried and I can't.

        Emmanuel Venisse made changes -
        Affects Version/s 1.1-beta-4 [ 13727 ]
        Assignee Emmanuel Venisse [ evenisse ]
        Fix Version/s 1.1-beta-2 [ 13606 ]
        Affects Version/s 1.1-alpha-1 [ 12082 ]
        Kevin Christmas added a comment - - edited

        I am struggling to recreate this issue with sample projects.

        My company has a fairly large product that we've set up like this:

        pom.xml
        ----> libraries/pom.xml
        ---------> library1/pom.xml
        ---------> library2/pom.xml
        ---------> library3/pom.xml
        ---------> libraryN/pom.xml
        ----> webmodules/pom.xml
        ---------> webmodule1/pom.xml
        ---------> webmodule2/pom.xml
        ---------> webmodule3/pom.xml
        ---------> webmoduleN/pom.xml

        After initially adding the root pom.xml and letting continuum load and build the rest, adding a notifications section to the root pom.xml will place continuum in a state where none of the projects in the tree can be saved to the database. Projects not in that inheritance chain will be unaffected, meaning you can still save them to the continuum database.

        I can reproduce this error 100% of the time with my company's project.

        I would love to scratch my own itch on this, but I'm struggling to see how the StoreManager on the StateManagerImpl class gets set in the first place.

        Brett Porter made changes -
        Fix Version/s 1.2 [ 13779 ]
        Wendy Smoak made changes -
        Fix Version/s 1.2.0 [ 13779 ]
        Fix Version/s 1.2.1 [ 14539 ]
        Emmanuel Venisse added a comment -

        Cannot reproduce with 1.2

        Emmanuel Venisse made changes -
        Resolution Cannot Reproduce [ 5 ]
        Assignee Emmanuel Venisse [ evenisse ]
        Status Open [ 1 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
        Mark Thomas made changes -
        Workflow jira [ 12710220 ] Default workflow, editable Closed status [ 12739914 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
        Mark Thomas made changes -
        Workflow jira [ 12947436 ] Default workflow, editable Closed status [ 12985457 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        336d 5h 48m 1 Emmanuel Venisse 13/Oct/08 15:35

          People

          • Assignee:
            Emmanuel Venisse
            Reporter:
            Kevin Christmas
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development