Uploaded image for project: 'Continuum'
  1. Continuum
  2. CONTINUUM-1511

Improve error handling when not able to resolv artifacts

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None

      Description

      When not able to resolve artifact, dump info about the artifact that was supposed to be resolved and the stack trace into the build log instead of getting "build error" and a stack trace in wrapper.log like this:

      INFO   | jvm 1    | 2007/10/05 10:11:12 | 2007-10-05 10:11:12,431 [pool-1-thread-1] ERROR BuildController:default        - Error executing action update-project-from-working-directory '
      INFO   | jvm 1    | 2007/10/05 10:11:12 | org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error executing action 'update-project-from-working-directory'
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction(DefaultBuildController.java:443)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:148)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:50)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at java.lang.Thread.run(Thread.java:595)
      INFO   | jvm 1    | 2007/10/05 10:11:12 | Caused by: org.apache.maven.continuum.execution.ContinuumBuildExecutorException: Error while mapping metadata:add.project.artifact.not.found.error
      INFO   | jvm 1    | 2007/10/05 10:11:12 | add.project.unknown.error
      INFO   | jvm 1    | 2007/10/05 10:11:12 | 
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.updateProjectFromCheckOut(MavenTwoBuildExecutor.java:168)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.apache.maven.continuum.core.action.UpdateProjectFromWorkingDirectoryContinuumAction.execute(UpdateProjectFromWorkingDirectoryContinuumAction.java
      :75)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       at org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction(DefaultBuildController.java:417)
      INFO   | jvm 1    | 2007/10/05 10:11:12 |       ... 8 more
      

        Activity

        olamy Olivier Lamy (*$^¨%`£) added a comment -

        fixed in rev 664117
        The stack trace will now contains the error message from maven :

        2008-06-06 22:40:53,343 [addMavenTwoProjectBackgroundThread] INFO  continuum  -
        org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download
         the artifact from any repository
        
          ghd:non-exists:pom:2.6.267676-beta-754-alpha-95
        
        from the specified remote repositories:
          central (http://repo1.maven.org/maven2)
        

          People

          • Assignee:
            olamy Olivier Lamy (*$^¨%`£)
            Reporter:
            trygvis@inamo.no Trygve Laugstøl
          • Votes:
            6 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development