Continuum
  1. Continuum
  2. CONTINUUM-1054

IllegalStateException stack adding pom

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.1-alpha-1
    • Fix Version/s: 1.2
    • Component/s: Web interface
    • Labels:
      None

      Description

      Adding a m2 pom from a web location causes this stack trace, although seems to work fine

      2006-12-13 10:46:07,109 [SocketListener0-1] INFO DispatcherUtils - Unable to find 'webwork.multipart.saveDir' property setting. Defaulting to javax.servlet.context.tempdir
      2006-12-13 10:46:07,156 [SocketListener0-1] WARN MultiPartRequest - Item is a file upload of 0 size, ignoring
      2006-12-13 10:46:07,156 [SocketListener0-1] ERROR DispatcherUtils - Error setting character encoding to 'UTF-8' - ignoring.
      java.lang.IllegalStateException: getReader() or getInputStream() called
      at org.mortbay.jetty.servlet.ServletHttpRequest.setCharacterEncoding(ServletHttpRequest.java:602)
      at javax.servlet.ServletRequestWrapper.setCharacterEncoding(ServletRequestWrapper.java:112)
      at com.opensymphony.webwork.dispatcher.DispatcherUtils.prepare(DispatcherUtils.java:392)
      at com.opensymphony.webwork.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:160)
      at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
      at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
      at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
      at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
      at com.opensymphony.webwork.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:88)
      at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
      at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:471)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
      at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:633)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
      at org.mortbay.http.HttpServer.service(HttpServer.java:909)
      at org.mortbay.http.HttpConnection.service(HttpConnection.java:816)
      at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:982)
      at org.mortbay.http.HttpConnection.handle(HttpConnection.java:833)
      at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)
      at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
      at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

        Activity

        Carlos Sanchez added a comment -

        for instance adding http://svn.codehaus.org/modello/trunk/pom.xml

        It might be because the "upload pom" field is also submitted and it's empty ?

        Edwin Punzalan added a comment -

        I can add the url above to continuum using trunk

        Carlos Sanchez added a comment -

        it can be added, but that stack is printed in the output

        Stephen Duncan Jr added a comment -

        I'm seeing the same error attempting to load from web location (Authenticated + SSL), and it is NOT working.

        Ellecer Valencia added a comment -

        This error is still happening on 1.1-beta2. Since a multi-module project can only be added using the URL, this is a bit of a show-stopper!

        I do not have any problems when adding an Ant project by specifying the URL. We are using Apache SSPI Auth + SVN, and the URL for the pom.xml that fails is inside our network, and is accessible from a browser or tortoiseSVN.

        I tried adding the URL above and I can't even add it because we are behind a company proxy. (sorry ,that should be a different bug report)

        Emmanuel Venisse added a comment -

        It isn't really an exception. The standalone Continuum embed jetty 5 and this exception come from jetty because the upload field is empty when you use the pom url.
        This issue will be fixed by an update of jetty but continuum works fine with this exception that is more a debug message than an exception

        Ellecer Valencia added a comment -

        As I said, I am getting results different from what the others have been getting.

        I am not just complaining about a stracktrace coming out in the logs. I am complaining that I cannot add a maven 2 project into Continuum at all. How can anyone say "it's not really an exception"? If you can't do what the app is supposed to let you do - what do you call that?

        The error message displayed in the interface is this:

        "The specified resource isn't a file or the protocol used isn't allowed."

        The stacktrace that comes out is identical to the one in this bug.

        Now is it possible that the same stacktrace is being thrown for entirely different reasons? A friend mentioned it might be a URL issue, but the URL has been parsed fine by Hudson and Bamboo, which are both Java webapps, so I don't think that's the case.

        Is there a config setting to increase the log levels as it might show a bit more info on what's going on?

        Should I add this as a different bug, since the situation described in the originating bug is a bit different from what I'm getting? (ie, they can add a project, while i can't)

        Benoit Guerout added a comment - - edited

        Any news about this issue (error message + unable to add Mavne 2 project),

        Actually we are not able to use Continuum at all because of this.

        Assume this is due to a SVN misconfiguration or a Jetty error, but in my point of view, it should be handle as a major priority...

        Benoit Guerout added a comment -

        Failed on Tomcat 5.5.17, same tace with no way to add a Maven2 Project

        Qingtian Wang added a comment -

        Just installed 1.1 final on redhat linux. Same issue. Can't add Maven 2 project at all.

        David J. Kordsmeier added a comment -

        I still see this issue as well in 1.1 standalone. Appears to me this is more than a minor issue for m2 users, but if you have the work around, then you can proceed. Work around was to add the project as a shell script project, and then continuum can deal with the checkout, and you will have to specify the path to maven with the lifecycle states you want to build. Path to maven and JAVA_HOME should be set in the environment prior to launch of the server. Can anyone else verify this workaround?

        Thomas Memenga added a comment -

        I got the same problem. It works on a Windows XP machine, but not on a Windows 2003 machine. I don't understand, why is this a minor issue? The error is not just cosmetic (at least in my case): There is no way to add the project.

        Johan Vogelzang added a comment - - edited

        We got the same problem. Running Continuum 1.2-SNAPSHOT standalone on linux. It is not possible to add a Maven2 project (multi module).. The wrapper log shows the same error as showed in this issue.
        Workaround:

        • Edit $CONTINUUM_HOME/apps/continuum/webapp/WEB-INF/classes/META-INF/plexus/application.xml
        • Uncomment the line: <allowedScheme>file</allowedScheme>
        • Restart Continuum
        • On the commandline checkout the needed project from your SCM
        • Open Continuum webinterface and add a Maven2 project by using a file url (file:///-path-to-local-checkout-/pom.xml)
          I hope that at least the priority of this bug will be increased, because it seriously motivates users to look for alternative's if this core function of the webinterface does not work properly.
        Brett Porter added a comment -

        in 1.2, we use Jetty6, and this problem is no longer present

        Geert Jan added a comment -

        1.2 isn't final yet. In my opinion this issue should be reopened....

        Brett Porter added a comment -

        a workaround you might try in the mean time is to replace the commons-fileupload in WEB-INF/lib with a newer version

        james obrien added a comment -

        That didn't work for me. I don't understand how this issue can be closed when it blocks users from adding projects?

        Brett Porter added a comment -

        1.2 is the next release, where the problem isn't relevant - unfortunately we can only provide workarounds in the mean time.

        If the above didn't work, you can grab the continuum-jetty module from svn and replace the WAR version with 1.1 to build a runtime bundle that includes the 1.1 release.

        Andreas Guther added a comment -

        I am using Version: 1.2 Build Number: 697023 and I still see the described behavior. We are unable to use continuum because of this issue.

        Wendy Smoak added a comment -

        This issue was for a minor problem with a stack trace showing up in the logs-- not the inability to add projects. As such it's marked as Won't Fix.

        (I tested adding the url that Carlos provided with the Continuum 1.2.2 release candidate and do not see the stack trace, so as Brett and Emmanuel mentioned, it was probably resolved as a side effect of upgrading some underlying components.)

        If you are having other problems such as the inability to add projects to Continuum, please ask on the user list or open a new issue with the details.

        Andreas Guther added a comment -

        Wendy,

        from reading all the other comments I do not think this is a simple and minor issue with nothing more than a strack trace in the logs that is irritating but harmless. If you read other comments here an in the mailing archives you might agree with me that there a plenty of users complaining that they are not able to use Continuum because they cannot add pom URLS as project definitions. For now i could get Continuum 1.2 running on Suse Linux to run using the workaround describe in this issue as well. But this is very, very impractical and makes 1.2 for us basically useless. We discuss right now going back to 1.1. One of the main reasons for us to use Continuum is the ease of setting up new projects based on just pointing to a pom file in our VCS.

        I just noticed that you are talking about a 1.2.2 release candidate and maybe I should try that one first.

        Andreas Guther added a comment -

        We did some more experimenting and it appears that Continuum is able to retrieve the pom file via HTTP.

        What we believe now is that we had an issue with the used password for our SVN server that ended with an exclamation point "!". I tried to checkout the project on command line with the --password argument to SVN and got some errors. I omitted then passing the password as argument and had to enter the password after SVN asked me for it. That finally triggered the checkout.

        I think this is rather a shell problem. However, the error message provided by Continuum is very misleading and since I found the same error messages described in this issue in our log file I was wrongly concluding that I am facing the same problem.

        I guess I will open a new issue describing the actual problem and the possible cause.

        Wendy Smoak added a comment -

        This would be much easier to discuss on the user list. CONTINUUM-1199 is already open for the inability to use special characters in passwords.


          People

          • Assignee:
            Brett Porter
            Reporter:
            Carlos Sanchez
          • Votes:
            7 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development