Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.1-alpha-1, 1.3.3 (Beta)
    • Fix Version/s: 1.3.5 (Beta)
    • Component/s: Core system
    • Labels:
      None

      Description

      It took 30+ secs to remove a project

        Activity

        Carlos Sanchez created issue -
        Carlos Sanchez made changes -
        Field Original Value New Value
        Fix Version/s 1.1 [ 12082 ]
        Carlos Sanchez added a comment -

        Seems fixed in latest code

        Carlos Sanchez made changes -
        Resolution Cannot Reproduce [ 5 ]
        Assignee Carlos Sanchez [ carlos ]
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 1.1 [ 12082 ]
        Peter Janes added a comment -

        I don't think I can reopen this bug (and this comment may be ignored as a result), but I'm seeing terrible performance when deleting projects in 1.3.3. If a project has a few hundred builds it can take over an hour to finish deleting, with mysql at 100% CPU the whole time.

        I have found a workaround: if I delete all of the individual builds by multi-selecting them all on the build history page, they're removed in a few seconds; with no builds left, deleting the project is very fast.

        Carlos Sanchez added a comment -

        reopened per user's comment

        Carlos Sanchez made changes -
        Assignee Carlos Sanchez [ carlos ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Resolution Cannot Reproduce [ 5 ]
        Carlos Sanchez made changes -
        Affects Version/s 1.3.3 [ 15105 ]
        Brett Porter made changes -
        Fix Version/s 1.3.5 [ 15641 ]
        Maria Catherine Tan added a comment -

        Hi Peter,

        There are a lot of performance improvements in 1.3.4, have you tried it using that version?

        Brett Porter added a comment -

        We still have this problem on vmbuild trying to delete the jUDDI projects. It seems to be a result of the large number of build results.

        Maria Catherine Tan made changes -
        Assignee Maria Catherine Tan [ ctan ]
        Maria Catherine Tan added a comment -

        Fixed in
        r822134 of 1.3.x branch
        r822135 of trunk

        Maria Catherine Tan made changes -
        Resolution Fixed [ 1 ]
        Status Reopened [ 4 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
        Mark Thomas made changes -
        Workflow jira [ 12709707 ] Default workflow, editable Closed status [ 12739309 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
        Mark Thomas made changes -
        Workflow jira [ 12946926 ] Default workflow, editable Closed status [ 12984929 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        9d 14h 48m 1 Carlos Sanchez 15/Dec/06 13:22
        Closed Closed Reopened Reopened
        1006d 22h 44m 1 Carlos Sanchez 17/Sep/09 13:06
        Reopened Reopened Closed Closed
        18d 12h 48m 1 Maria Catherine Tan 06/Oct/09 01:55

          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Carlos Sanchez
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development