Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: ManifoldCF 1.2
    • Fix Version/s: ManifoldCF 1.5
    • Labels:
      None
    • Environment:

      java version "1.6.0_31"
      Red Hat Enterprise Linux Server release 5.7 (Tikanga)
      PostgreSQL version 9.2.8 running on Scientific Linux release 6.2 (Carbon)

      Description

      ERROR 2013-06-24 10:39:34,999 (Worker thread '1') - Worker thread aborting and restarting due to database connection reset: Database exception: SQLException doing query (25P02): ERROR: current transaction is aborted, commands ignored until end of transaction block
      org.apache.manifoldcf.core.interfaces.ManifoldCFException: Database exception: SQLException doing query (25P02): ERROR: current transaction is aborted, commands ignored until end of transaction block
      	at org.apache.manifoldcf.core.database.Database.executeViaThread(Database.java:717)
      	at org.apache.manifoldcf.core.database.Database.executeUncachedQuery(Database.java:745)
      	at org.apache.manifoldcf.core.database.Database$QueryCacheExecutor.create(Database.java:1430)
      	at org.apache.manifoldcf.core.cachemanager.CacheManager.findObjectsAndExecute(CacheManager.java:144)
      	at org.apache.manifoldcf.core.database.Database.executeQuery(Database.java:186)
      	at org.apache.manifoldcf.core.database.DBInterfacePostgreSQL.performQuery(DBInterfacePostgreSQL.java:822)
      	at org.apache.manifoldcf.crawler.jobs.JobManager.addDocuments(JobManager.java:4148)
      	at org.apache.manifoldcf.crawler.system.WorkerThread$ProcessActivity.processDocumentReferences(WorkerThread.java:2017)
      	at org.apache.manifoldcf.crawler.system.WorkerThread$ProcessActivity.flush(WorkerThread.java:1948)
      	at org.apache.manifoldcf.crawler.system.WorkerThread.run(WorkerThread.java:562)
      Caused by: org.postgresql.util.PSQLException: ERROR: current transaction is aborted, commands ignored until end of transaction block
      	at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2102)
      	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1835)
      	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
      	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500)
      	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388)
      	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:273)
      	at org.apache.manifoldcf.core.database.Database.execute(Database.java:862)
      	at org.apache.manifoldcf.core.database.Database$ExecuteQueryThread.run(Database.java:677)
      

        Activity

        Karl Wright added a comment -

        This has been around a long time; if we can fix the underlying cause of the failure Ahmet is seeing, we can postpone until after 1.3.

        Karl Wright added a comment -

        Underlying cause was (I think) addressed. But now I have time to look at reproducing this problem under controlled conditions and fixing the reset logic to not fail.

        Karl Wright added a comment -

        r1520939 makes the necessary infrastructure changes to allow us to seamlessly override the database driver during testing.

        Karl Wright added a comment -

        r1553520


          People

          • Assignee:
            Karl Wright
            Reporter:
            Ahmet Arslan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development