Uploaded image for project: 'Commons Configuration'
  1. Commons Configuration
  2. CONFIGURATION-217

Possible Maven2 POM dependency clash for Servlet-API

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Component/s: None
    • Labels:
      None
    • Environment:

      Maven 2.0.4
      Windows XP

      Description

      As described by ASF bug #33476 Commons Configurations shall depend on Servlet-API 2.4. The current Maven2 POM of Commons Configuration 1.2 shows a dependency on Servlet-API 2.3. This is not only a mismatch between Commons Configurations' build configuration and its Maven2 POM but also prevents Maven2 projects from using the Servlet-API 2.4 if also using Commons Configuration 1.2.

      Could it be possible to fix Commons Configuration 1.2's Maven2 POM to include a dependency on Servlet-API 2.4, please?

      With best regards, Christoph

      P.S.: My thanks for the quick fix of the Commons Collection dependency problem within Commons Configuration.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              cenowa@makdata.de Christoph Cenowa
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: