It's very confusing to have two different TransformedMap classes in different packages: map, splitmap.
Indeed the Test class has to take special care with the serialised file name to avoid a clash.
Since we can break binary compat in v4, now is the time to rename one of the classes.
Perhaps rename as follows:
splitmap/TransformedMap => splitmap/TransformedGetPutMap