Uploaded image for project: 'Commons Codec'
  1. Commons Codec
  2. CODEC-104

Add a function for the classical Unix crypt(3) hash

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 1.7
    • Labels:
      None

      Description

      The Sun Java APIs lack a function for the classical Unix crypt(3) hash that was used in e.g. /etc/passwd or Apache htpasswd and is still widely used dispite the availablitity of better algorithms like MD5 or SHA.

      Apart from me cursing Sun for producing monster crypto APIs but missing the little things that one really needs, there are already several Apache projects
      that implemented UnixCrypt for their own:
      org.apache.directory.studio.ldapbrowser.core.utils.UnixCrypt
      org.apache.fulcrum.crypto.impl.UnixCrypt
      and maybe others

      bye,

      christian

        Activity

        ggregory@seagullsw.com ggregory@seagullsw.com added a comment -

        Perhaps a o.a.c.c.unix package?

        seelmann Stefan Seelmann added a comment -

        Very true, such a class in commons would be very cool.

        The class in Apache Directory Studio is just borrowed, see comments in SVN:
        http://svn.apache.org/repos/asf/directory/studio/trunk/ldapbrowser.core/src/main/java/org/apache/directory/studio/ldapbrowser/core/utils/UnixCrypt.java

        sgoeschl Siegfried Goeschl added a comment -

        And I borrowed it from Apache Directory Study to provide the functionality in fulcrum ...

        sgoeschl Siegfried Goeschl added a comment -

        Do we have more crypto related stuff or in other words - would this be a commons-crypto or going into lang or codec?

        juliusdavies Julius Davies added a comment -

        +1 to o.a.c.c.unix! Gary, do you want to just pull whatever code is currently in directory.apache.org ?

        bayard Henri Yandell added a comment -
        garydgregory Gary Gregory added a comment -

        Marking as duplicate of the more complete CODEC-133

        garydgregory Gary Gregory added a comment -

        Released in 1.7 today.

        garydgregory Gary Gregory added a comment -

        Duplicate of CODEC-133.


          People

          • Assignee:
            Unassigned
            Reporter:
            lathspell Christian Brunotte
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development