Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-beta-1
    • Fix Version/s: 3.0.0-beta-1
    • Component/s: cocoon-optional
    • Labels:
      None

      Description

      Remove jakarta-regexp dependency from all POMs: the only class using this is, at the moment, DirectoryGenerator, in cocoon-optional.
      This class should be refactored to make use of java.util.regexp.* instead.

        Activity

        Hudson added a comment -
        Integrated in Cocoon-trunk #177 (See [https://builds.apache.org/job/Cocoon-trunk/177/])
            [COCOON3-76] Applying provided patch (Revision 1340929)

             Result = SUCCESS
        ilgrosso : http://svn.apache.org/viewvc/?view=rev&rev=1340929
        Files :
        * /cocoon/cocoon3/trunk/cocoon-optional/src/main/java/org/apache/cocoon/optional/pipeline/components/sax/directory/DirectoryGenerator.java
        Francesco Chicchiriccò added a comment -
        Well, I think that in C3 we can not be worried about backward compatibility issues: I'll apply your patch then.
        Javier Puerto added a comment -
        IMO "matches" method makes more sense, less ambiguity and also it's the behaviour I should expect. The problem is the backwards compatibility.
        Francesco Chicchiriccò added a comment -
        As reported in the provided StackOverflow question, using find() instead of matches() should keep the same behavior as previous.

        WDYT?
        Javier Puerto added a comment -
        The patch is valid for Cocoon 2.2 but there are differences in behaviour. See http://stackoverflow.com/questions/6582569/differences-between-jakarta-regexp-and-java-6-java-util-regex

        Javier Puerto added a comment -
        Switch jakarta-regex to java.util.regex
        Simone Tripodi added a comment -
        +1 makes a lot of sense!

          People

          • Assignee:
            Francesco Chicchiriccò
            Reporter:
            Francesco Chicchiriccò
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development