Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha-2
    • Component/s: cocoon-stax
    • Labels:
      None

      Description

      We experimented with wrappers to add SAX-components to StAX pipelines and with Adapters between StAX pipelines and SAX pipelines. IMO they work quite fine :)

      The problem with this patch is that it relies on the stax-utils project. Most classes in o.a.c.stax.converter.util are redistrubuted from the stax-utils (https://stax-utils.dev.java.net/) project. This was required since there's an architectural issue so that stax-utils can not be used directly as reference. I posted at the stax-utils dev mailing list two weeks ago, if they could make some of their methods protected instead of private so that we could resolve this issue, but I did not receive an answer.

      I created a seperated issue for this problem since there's the opened question of how to mark the redistributed classes from the stax-utils project. I think Reinhard know ways of how to resolve this problem :)

      I created this issue as an subtask of COCOON3-18 since first the patch of COCOON3-18 have to be applied before this patch could be used.
      1. cocoon-stax-license.patch
        15 kB
        Andreas Pieber
      2. cocooon-stax-converter.patch
        91 kB
        Andreas Pieber

        Activity

        Reinhard Poetz added a comment -
        I've just committed the license patch. Thanks!
        Andreas Pieber added a comment -
        There are some classes which have no license in the original code... Namely:

        org.apache.cocoon.stax.converter.util.XMLFilterImplEx
        org.apache.cocoon.stax.converter.util.StaticNamespaceContext
        org.apache.cocoon.stax.converter.util.DummyLocator

        What should I do with them? At the moment I did not modify the license there at all and let the sun-header added by you.

        Further more I documented where I taken the classes from. I did this in javadoc:

        /**
         * SAX ContentHandler that writes events to a StAX {@link XMLEventConsumer}.
         *
         * @author Christian Niles
         * @version $Revision: 1.5 $
         *
         * @version from stax-utils stable version stax-utils-20070216
         * @original javanet.staxutils.StAXEventContentHandler, javanet.staxutils.StAXContentHandler
         * @modified true (added SAXConsumer and made one class out of StAXEventContentHandler and StAXContentHandler)
         */
        public class StAXEventContentHandler extends DefaultHandler implements SAXConsumer {

        or would it better to make them inline?

        /**
         * SAX ContentHandler that writes events to a StAX {@link XMLEventConsumer}.
         *
         * @author Christian Niles
         * @version $Revision: 1.5 $
         */
        public class StAXEventContentHandler extends DefaultHandler implements SAXConsumer {
        /*
        * @version from stax-utils stable version stax-utils-20070216
        * @original javanet.staxutils.StAXEventContentHandler, javanet.staxutils.StAXContentHandler
        * @modified true (added SAXConsumer and made one class out of StAXEventContentHandler and StAXContentHandler)
        */
        Reinhard Poetz added a comment -
        Yes, getting a patch with the original license headers would be great. We don't want to keep the SVN because they will be overridden anyway.

        Could you also please add a comment of the revision number or release version that those files are taken from?
        Andreas Pieber added a comment -
        The mail I wrote could be found here: https://stax-utils.dev.java.net/servlets/ReadMsg?list=dev&msgNo=298

        The mailing list I wrote to was dev@stax-utils.dev.java.net. I'm registered to this list and will post the link to the answer as soon I'll get one (but I'm not sure if I'll ever get one...).
        Andreas Pieber added a comment -
        The stax-utils components directly taken from stax-utils are:

        org.apache.cocoon.stax.converter.util.DummyLocator
        org.apache.cocoon.stax.converter.util.ExtendedNamespaceContext
        org.apache.cocoon.stax.converter.util.SimpleNamespaceContext
        org.apache.cocoon.stax.converter.util.StaticNamespaceContext
        org.apache.cocoon.stax.converter.util.XMLFilterImplEx

        Components which are taken from the stax-utils project, but which were modified are:

        org.apache.cocoon.stax.converter.util.StAXEventContentHandler
        org.apache.cocoon.stax.converter.util.XMLEventToContentHandler

        What do you mean with: "point me to the original license"? The original license from the source code is exactly what you added again with the difference that all of them contain an id like:

        $Id: ExtendedNamespaceContext.java,v 1.1 2004/07/05 23:10:46 cniles Exp $

        and some of them does not have a sun-copyright header (Copyright (c) 2004, Sun Microsystems, Inc.) but a copyright of the autor itself (Copyright (c) 2004, Christian Niles, unit12.net). Should I change all licenses back to the original and provide a patch?
        Reinhard Poetz added a comment -
        I've applied the patch but keep the issue open until the Cocoon PMC has confirmed that I did the licensing part correctly.
        Reinhard Poetz added a comment -
        According to http://www.apache.org/legal/src-headers.html#3party we should not modify or remove any copyright notices or licenses within third-party works. This means we have to keep the original license header (According to https://stax-utils.dev.java.net/ Stax-Utils has a BSD style license) and have to include a reference in the NOTICE file.

        Andreas (or anybody else), could you please list all the files that are taken from StAXUtils and point me to the original license? Thanks!
        Reinhard Poetz added a comment - - edited
        Andreas, can you give us a pointer to your message sent to the stax-utils community? (Just for the records)

          People

          • Assignee:
            Reinhard Poetz
            Reporter:
            Andreas Pieber
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development