Uploaded image for project: 'Cocoon'
  1. Cocoon
  2. COCOON-2334

[PATCH] cocoon 2.1 branch (head) build system

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1.12
    • Fix Version/s: 2.1.12
    • Component/s: - Build System: Ant
    • Labels:
      None
    • Urgency:
      Blocker
    • Other Info:
      Patch available

      Description

      On my System is only jdk 7 installed, so during compiling the actual cocoon 2.1 branch I got the following error:

      cocoon-block-batik-compile:
      Compiling 2 source files to C:\work\eclipse\Cocoon2_1_branch\build\cocoon\blocks\batik\dest
      javac: target release 1.6 conflicts with default source release 1.7

      BUILD FAILED
      C:\work\eclipse\Cocoon2_1_branch\tools\targets\compile-build.xml:264: The following error occurred while executing this line:
      C:\work\eclipse\Cocoon2_1_branch\build\cocoon\temp\blocks-build.xml:1119: The following error occurred while executing this line:
      C:\work\eclipse\Cocoon2_1_branch\build\cocoon\temp\blocks-build.xml:100: Compile failed; see the compiler error output for details.

      The patch will fix this situation by adding source="${source.vm}" to javac calls.

        Attachments

          Activity

            People

            • Assignee:
              ilgrosso Francesco Chicchiriccò
              Reporter:
              powerstat Kai Hofmann
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: