Cocoon
  1. Cocoon
  2. COCOON-2186

Suggest list .. initial value not being displayed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.11
    • Fix Version/s: 2.1.12
    • Component/s: Blocks: Ajax, Blocks: Forms
    • Labels:
      None
    • Urgency:
      Urgent
    • Affects version (Component):
      Blocks: Forms

      Description

      For the forms field of type suggest with a suggestion list the initial value is not being displayed ... this dint happen for version 2.1.10 .. but when i upgraded to version 2.1.11 it no longer sets the initial value .. this bug is also present for the sample
      http://cocoon.zones.apache.org/demos/release/samples/blocks/forms/do-suggest.flow


      Initial value of the widget is 16, the widget must show "Bruno Dumon".
      <fd:datatype base="integer"/>
            <fd:initial-value>16</fd:initial-value>
            <fd:suggestion-list type="javascript">

      after debugging i found out that the widgets value is being set but it isnt passed on to DOJO as initial value when the DOJO widget is created ..

        Activity

        Carlos Chávez added a comment -
        Hi Imran.
        Hi All.

        I figure out that the issue is because some method on dojo is setting the mimetype to "text/json" instead "text/json-comment-filtered". This need to be fixed by Dojo team, i think.

        On the cocoon site we need to wrap the JSON array wit h /* */ and set the mimetype in the json serializer to "text/json-comment-filtered" instead "text/javascript".

        I posted a message about this on the dojo forum see: http://dojotoolkit.org/forum/dojo-0-4-x-legacy/dojo-0-4-x-support/combobox-change-mimetype-text-json-text-json-comment-filt

        Now, we are using a legacy version of dojo and i checked the code in the trunk of dojo and it seems like even if we update the dojo version the issue it will still there because the method in the dojo trunk still setting the mimetype as "text/json".

        meanwhile i think we can rewrite the dojo.widget.incrementalComboBoxDataProvider, but this is a hack.

          People

          • Assignee:
            Antonio Gallardo
            Reporter:
            imran pariyani
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development