Cocoon
  1. Cocoon
  2. COCOON-1848

[PATCH] using setRequired in Ajax mode does not generate bu:replace

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.9, 2.1.10
    • Fix Version/s: 2.1.10, 2.2
    • Component/s: Blocks: Forms
    • Labels:
      None
    • Other Info:
      Patch available

      Description

      When you use method setRequired on Field, BrowserUpdateTransformer does not generate a bu:replace

      a litle patch to fix that :

      --- Field.java 2006-05-10 15:52:14.249081500 +0200
      +++ Field.java 2006-05-10 15:49:32.847326500 +0200
      @@ -476,6 +476,7 @@

           public void setRequired(boolean required) {
               this.required = required;
      + getForm().addWidgetUpdate(this);
           }

           /**

        Activity

        Hide
        Antonio Gallardo added a comment -
        Thanks for the patch. It was applied in 2.1.10-dev and 2.2-dev. Feel free to reopen the issue if needed.
        Show
        Antonio Gallardo added a comment - Thanks for the patch. It was applied in 2.1.10-dev and 2.2-dev. Feel free to reopen the issue if needed.

          People

          • Assignee:
            Antonio Gallardo
            Reporter:
            Vincent Demay
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development