Chemistry
  1. Chemistry
  2. CMIS-60

TCK fails on type entry - does not expect elements with xsi:type="cmis:cmisTypeDocumentDefinitionType"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: OpenCMIS 1.0.0
    • Component/s: tck
    • Labels:
      None

      Description

      In the abbreviated feed below the xsi:type="cmis:cmisTypeDocumentDefinitionType" causes the TCK to fail.

      TRACE TCKMessageWriter - Validating response of content type application/atom+xml;type=entry
      INFO TCKMessageWriter - Failed Validation: org.xml.sax.SAXParseException: UndeclaredPrefix: Cannot resolve 'cmis:cmisTypeDocumentDefinitionType' as a QName: the prefix 'cmis' is not declared.

      <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
      <atom:feed xmlns:atom="http://www.w3.org/2005/Atom" xmlns:app="http://www.w3.org/2007/app" xmlns:cmis="http://docs.oasis-open.org/ns/cmis/core/200908/" xmlns:cmisra="http://docs.oasis-open.org/ns/cmis/restatom/200908/" xmlns:cmism="http://docs.oasis-open.org/ns/cmis/messaging/200908/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      ...
      <atom:entry>
      <atom:title type="text">cmis:document</atom:title>
      <atom:id>http://devcmis:8080/resources/cmis/repositories/documentum/types/cmis:document</atom:id>
      <cmisra:type xsi:type="cmis:cmisTypeDocumentDefinitionType">
      <cmis:id>cmis:document</cmis:id>

        Activity

        Florent Guillaume added a comment -

        This seems to be a CXF problem due to a JAXB bug, see CXF-2340 and https://jaxb.dev.java.net/issues/show_bug.cgi?id=665

        David Caruana added a comment -

        Norrie,

        I've been trying to reproduce this issue without success. I've attempted to reconstruct a complete response from your snippet, but validation succeeds.

        Is it possible for you to attach the complete response?

        I also notice the trace message 'Validating response of content type application/atom+xml;type=entry' even though it's a feed. It's very unlikely this has any impact on the error, but it's something to note.

        David Caruana added a comment -

        It is expected that this TCK will be replaced by the OpenCMIS based TCK.

        Florian Müller added a comment -

        This TCK has been superseded by the OpenCMIS TCK.


          People

          • Assignee:
            Unassigned
            Reporter:
            Norrie Quinn
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development