Chemistry
  1. Chemistry
  2. CMIS-433

problem with SELECT * FROM VersionableType

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: OpenCMIS 0.5.0
    • Fix Version/s: OpenCMIS 0.6.0
    • Labels:
      None
    • Environment:

      Using matching 0.5.0 releases of Workbench and the inMemoryServer - Windows 7...

      Description

      Using matching 0.5.0 releases of Workbench and the inMemoryServer (but this happened with previous versions too)

      I can do this select and it works fine using the query function of Workbench.
      SELECT * FROM DocumentTopLevel as d where d.StringPropTopLevel = 'xxx'

      However if I do the same function using VersionableType I get a nullPointer exception at the server (which propagates back to workbench)
      SELECT * FROM VersionableType as d where d.VersionedStringProp = 'xxx'

      Not seeing anything wrong with this query. Need this to work for the IOD demo.

        Activity

        jay brown added a comment -

        Tested binary with Jens' patch. Problem is fixed.

        jay brown added a comment -

        I just grabbed the latest binaries as of earlier today and both problems are gone now. The query works fine and the NPE is gone as well. Thanks for the fix Jens!

        Jens Hübel added a comment -

        Jay I found some issues with updating properties on versioned documents. These result in lost updates after check-in. They are not always easy to detect as for example the workbench maintains a client side copy so you notice the problem only after a refresh. As a side effect query fails on those versions if where clause checks for these updated values. I have committed a fix to subversion.

        However I was not able to reproduce your null-pointer exception. Could you attach a stacktrace to help me identifying this? Could you perhaps also verify that the unit test testVersionsWithQuery() in class EvalQueryTest.java of the InMemoryServer successfully passes in your environment? It does almost the same (mvn test includes this test).

        Using the latest source I was able to run the query from above in the CMIS workbench.

        Thanks!


          People

          • Assignee:
            Jens Hübel
            Reporter:
            jay brown
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development