Chemistry
  1. Chemistry
  2. CMIS-247

Fix maven build when starting from scratch

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.1.0-incubating
    • Component/s: build&release
    • Labels:
      None

      Description

      A build from scratch (i.e., without older SNAPSHOT versions in the local repository) fails because of a confusion between maven packaging and maven type for the OSGi bundles.

      To reproduce, putting aside the content of .m2/repository/org/apache/chemistry/opencmis and do (assuming all other non-chemistry dependencies have already been loaded):

      mvn -DskipTests -o clean package
      ...
      [INFO] Building OpenCMIS Commons API
      ... (ok) ...
      [INFO] Building OpenCMIS Commons Implementation
      [INFO] Failed to resolve artifact.
      1) org.apache.chemistry.opencmis:chemistry-opencmis-commons-api:jar:0.1.0-incubating-SNAPSHOT
      Path to dependency:
      1) org.apache.chemistry.opencmis:chemistry-opencmis-commons-impl:bundle:0.1.0-incubating-SNAPSHOT
      2) org.apache.chemistry.opencmis:chemistry-opencmis-commons-api:jar:0.1.0-incubating-SNAPSHOT
      1 required artifact is missing.

      So it's in the process of building
      chemistry-opencmis-commons-impl:bundle
      and does not find
      chemistry-opencmis-commons-api:jar
      which is logical since what it just built is chemistry-opencmis-commons-api:bundle

        Activity

        Florent Guillaume added a comment -

        Fixed by not using the "bundle" packaging but just using "jar" packaging with the "manifest" goal of maven-bundle-plugin.

        http://svn.apache.org/viewvc?rev=991926&view=rev


          People

          • Assignee:
            Florent Guillaume
            Reporter:
            Florent Guillaume
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development