Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-6464

[KVM:basic zone- upgrade to 4.3],after any vm restart,all the nics are plugged to default bridge even though trafiic labels are being used

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 4.3.0
    • Fix Version/s: 4.4.0, 4.3.1
    • Component/s: Management Server
    • Security Level: Public (Anyone can view this level - this is the default.)
    • Labels:
      None

      Description

      Steps:
      1. create a KVM basic zone with 2 nics on host (pre 4.3 build)
      2.use cloudbr0 for management and cloudbr1 for guest by specifying the traffic labels in the physical networks.

      3.deploy few vms
      4.upgrade to felton GA build as per the Upgrade instructions.

      actual result:

      Upgrade successful but all the vnets that were attached to cloudbr1 before upgrade are attached to cloudbr0.

      Due to this network connectivity is lost.

      Expected result:

      Even after upgrade ,all the vnets should be attached to the same bridge as before upgrade.

      ex:

      before Upgrade : this vms(i-5-616-VM) nic was attached to cloudbr1 and after upgrade and VM stop/start.
      the network rules are getting programmed in cloudbr0 .check below output

      ,984 DEBUG [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-2:null) Executing: /usr/share/cloudstack-common/scripts/vm/network/security_group.py default_network_rules --vmname i-5-616-VM --vmid 616 --vmip 10.x.x245 --vmmac 06:14:48:00:00:7f --vif vnet15 --brname cloudbr0 --nicsecips 0:

      dumpxml output for i-5-616-VM after upgrade(& after VM restart)
      *****************************************************

      virsh # dumpxml 38
      <domain type='kvm' id='38'>
      <name>i-5-616-VM</name>
      <uuid>87557942-1393-49b3-a73e-ae24c40541d1</uuid>
      <description>Other CentOS (64-bit)</description>
      <memory unit='KiB'>2097152</memory>
      <currentMemory unit='KiB'>2097152</currentMemory>
      <vcpu placement='static'>1</vcpu>
      <cputune>
      <shares>1000</shares>
      </cputune>
      <os>
      <type arch='x86_64' machine='rhel6.2.0'>hvm</type>
      <boot dev='cdrom'/>
      <boot dev='hd'/>
      </os>
      <features>
      <acpi/>
      <apic/>
      <pae/>
      </features>
      <cpu>
      </cpu>
      <clock offset='utc'/>
      <on_poweroff>destroy</on_poweroff>
      <on_reboot>restart</on_reboot>
      <on_crash>destroy</on_crash>
      <devices>
      <emulator>/usr/libexec/qemu-kvm</emulator>
      <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/mnt/041e5d8e-d9c1-346d-aea9-cd9c7b80a211/75544e9d-a4c9-4a94-943e-b20827676a27'/>
      <target dev='hda' bus='ide'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
      </disk>
      <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw' cache='none'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <alias name='ide0-1-0'/>
      <address type='drive' controller='0' bus='1' target='0' unit='0'/>
      </disk>
      <controller type='usb' index='0'>
      <alias name='usb0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
      </controller>
      <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
      </controller>
      <interface type='bridge'>
      <mac address='06:14:48:00:00:7f'/>
      <source bridge='cloudbr0'/>
      <target dev='vnet15'/>
      <model type='e1000'/>
      <bandwidth>
      <inbound average='25600' peak='25600'/>
      <outbound average='25600' peak='25600'/>
      </bandwidth>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
      </interface>
      <serial type='pty'>
      <source path='/dev/pts/12'/>
      <target port='0'/>
      <alias name='serial0'/>
      </serial>
      <console type='pty' tty='/dev/pts/12'>
      <source path='/dev/pts/12'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
      </console>
      <input type='tablet' bus='usb'>
      <alias name='input0'/>
      </input>
      <input type='mouse' bus='ps2'/>
      <graphics type='vnc' port='5912' autoport='yes' listen='10.x.x.3'>
      <listen type='address' address='10.147.37.3'/>
      </graphics>
      <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
      </video>
      <memballoon model='virtio'>
      <alias name='balloon0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
      </memballoon>
      </devices>
      <seclabel type='none'/>
      </domain>

      its also applicable to new vm deployments.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sadhu sadhu suresh
            • Votes:
              6 Vote for this issue
              Watchers:
              17 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: