CloudStack
  1. CloudStack
  2. CLOUDSTACK-596

DeployVM command takes a lot of time to return job id

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: pre-4.0.0, 4.0.0
    • Fix Version/s: 4.1.0
    • Component/s: Management Server
    • Security Level: Public (Anyone can view this level - this is the default.)
    • Labels:
      None

      Description

      This is a perf issue typically seen for larger deployments (advanced zone, user accounts ~4k, lot of guest networks). The issue happens when deployVM is called without 'networkids' parameter. In this case a search is done to identify the default guest network to use for deploying VM. The search logic doesn't scale up for larger deployments resulting in delay in returning async job id.

      Tests results showed that for ~4k user accounts and similar number of guest networks it takes approx. 15 secs. to return async job id.

        Activity

        Hide
        Joe Brockmeier added a comment -

        I don't see a fix available for this yet, so it can go into 4.0.2 or 4.1.0 when we have a patch.

        Show
        Joe Brockmeier added a comment - I don't see a fix available for this yet, so it can go into 4.0.2 or 4.1.0 when we have a patch.
        Hide
        Koushik Das added a comment -
        Show
        Koushik Das added a comment - Review posted https://reviews.apache.org/r/8441/
        Hide
        Koushik Das added a comment -

        Applied in master, pl. close the review;

        CLOUDSTACK-596 : DeployVM command takes a lot of time to return job id Issue happens...
        authorKoushik Das <koushik.das@citrix.com>
        Mon, 10 Dec 2012 08:26:51 +0000 (13:26 +0530)
        committerAbhinandan Prateek <aprateek@apache.org>
        Mon, 10 Dec 2012 09:32:53 +0000 (14:32 +0530)
        commit238c55fb6e40220cbbf60b241a902cdc7ccf8d37

        Show
        Koushik Das added a comment - Applied in master, pl. close the review; CLOUDSTACK-596 : DeployVM command takes a lot of time to return job id Issue happens... authorKoushik Das <koushik.das@citrix.com> Mon, 10 Dec 2012 08:26:51 +0000 (13:26 +0530) committerAbhinandan Prateek <aprateek@apache.org> Mon, 10 Dec 2012 09:32:53 +0000 (14:32 +0530) commit238c55fb6e40220cbbf60b241a902cdc7ccf8d37
        Hide
        Musayev, Ilya added a comment -

        Hi Koushik,

        Since it's not a feature addition but a bug fix, is there a chance we can roll this into 4.0.1?

        Thank you,
        ilya

        Show
        Musayev, Ilya added a comment - Hi Koushik, Since it's not a feature addition but a bug fix, is there a chance we can roll this into 4.0.1? Thank you, ilya
        Hide
        Koushik Das added a comment -

        Ilya,

        This can be added to 4.0.1 as well. Please send out a merge request to the mailing list and someone can definitely help out.

        -Koushik

        Show
        Koushik Das added a comment - Ilya, This can be added to 4.0.1 as well. Please send out a merge request to the mailing list and someone can definitely help out. -Koushik
        Hide
        Chip Childers added a comment -

        closing since 4.1.0 is now released

        Show
        Chip Childers added a comment - closing since 4.1.0 is now released

          People

          • Assignee:
            Koushik Das
            Reporter:
            Koushik Das
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development