CloudStack
  1. CloudStack
  2. CLOUDSTACK-185

install script says "No package cloud-premium available"

    Details

      Description

      Steps:

      1.Download the new build rhel6.3
      2.Install the management server
      3.try to install the usage server

      Actual result:
      fail to install the usage server and it looking for depency package for JSVC.i think we don't require this package for usage server.

      Also installer says no package cloud-premium package available

      [root@rhel63 hh]# ./install.sh
      Setting up the temporary repository...
      Cleaning Yum cache...
      Loaded plugins: product-id, subscription-manager
      Updating certificate-based repositories.
      Unable to read consumer identity
      Cleaning repos: cloud-temp rhel
      2 metadata files removed
      Welcome to the Cloud.com CloudStack Installer. What would you like to do?

      A) Install the Agent
      B) Install BareMetal Agent
      S) Install the Usage Monitor
      U) Upgrade the CloudStack packages installed on this computer
      R) Stop any running CloudStack services and remove the CloudStack packages from this computer
      E) Remove the MySQL server (will not remove the MySQL databases)
      Q) Quit

      > s
      Installing the Usage Server...
      Loaded plugins: product-id, subscription-manager
      Updating certificate-based repositories.
      Unable to read consumer identity
      cloud-temp | 1.3 kB 00:00 ...
      rhel | 4.0 kB 00:00 ...
      Setting up Install Process
      No package cloud-premium available.
      Resolving Dependencies
      --> Running transaction check
      ---> Package cloud-usage.x86_64 0:4.0.0-0.22.el6.4.0 will be installed
      --> Processing Dependency: jsvc for package: cloud-usage-4.0.0-0.22.el6.4.0.x86_64
      --> Finished Dependency Resolution
      Error: Package: cloud-usage-4.0.0-0.22.el6.4.0.x86_64 (cloud-temp)
      Requires: jsvc
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

        Activity

        Hide
        Alex Huang added a comment -

        I think this is actually similar to the problem that's been resolved for management server. Search for JSVC.

        But the second one is not correct. There is no cloud-premium package any more.

        Show
        Alex Huang added a comment - I think this is actually similar to the problem that's been resolved for management server. Search for JSVC. But the second one is not correct. There is no cloud-premium package any more.
        Hide
        Rohit Yadav added a comment -

        This is fine, the jsvc package exists for RHEL and jsvc is a package used to daemonize or run java process as daemon. It's used in agent, client and usage init.d scripts and primarily used in ubuntu.

        Pradeep Soundararajan: I check spec files, the issue is in the install.sh script which tries to install cloud-premium package and fails. Pl. fix in install.sh

        The issue with cloud-usage and why it failed:
        https://issues.apache.org/jira/browse/CLOUDSTACK-81#comment-13461691

        Show
        Rohit Yadav added a comment - This is fine, the jsvc package exists for RHEL and jsvc is a package used to daemonize or run java process as daemon. It's used in agent, client and usage init.d scripts and primarily used in ubuntu. Pradeep Soundararajan : I check spec files, the issue is in the install.sh script which tries to install cloud-premium package and fails. Pl. fix in install.sh The issue with cloud-usage and why it failed: https://issues.apache.org/jira/browse/CLOUDSTACK-81#comment-13461691
        Hide
        Rohit Yadav added a comment -

        QA is trying to install these packages with no cent/rhel yum repo [0], but a iso media, hence it fails to find/install jsvc. For now, they can manually install jsvc rpm:
        http://rpmfind.net/linux/rpm2html/search.php?query=jsvc

        Also see Edison's comments: https://issues.apache.org/jira/browse/CLOUDSTACK-78?focusedCommentId=13459981&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13459981

        [0] /etc/yum.repos.d/rhel6.repo:
        [rhel]
        name=rhel6
        baseurl=file:///media
        enabled=1
        gpgcheck=0

        Show
        Rohit Yadav added a comment - QA is trying to install these packages with no cent/rhel yum repo [0] , but a iso media, hence it fails to find/install jsvc. For now, they can manually install jsvc rpm: http://rpmfind.net/linux/rpm2html/search.php?query=jsvc Also see Edison's comments: https://issues.apache.org/jira/browse/CLOUDSTACK-78?focusedCommentId=13459981&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13459981 [0] /etc/yum.repos.d/rhel6.repo: [rhel] name=rhel6 baseurl= file:///media enabled=1 gpgcheck=0
        Hide
        David Nalley added a comment -

        This is not a bug. jsvc is now required for installation.

        Please do file a docs bug if the docs currently indicate that you can install from only the CD/DVD iso.

        Show
        David Nalley added a comment - This is not a bug. jsvc is now required for installation. Please do file a docs bug if the docs currently indicate that you can install from only the CD/DVD iso.
        Hide
        sadhu suresh added a comment -

        Hi David,

        what about "cloud-premium".. are we addressing this issue .as per Alex comments#( added a comment - 23/Sep/12 15:32 ).we don't require to check for cloud-premium package.so this need to be addressed.

        do you want me raise seperate issue for this or no need(shall i reopen this bug by changing the description of the bug )

        regards
        sadhu

        Show
        sadhu suresh added a comment - Hi David, what about "cloud-premium".. are we addressing this issue .as per Alex comments#( added a comment - 23/Sep/12 15:32 ).we don't require to check for cloud-premium package.so this need to be addressed. do you want me raise seperate issue for this or no need(shall i reopen this bug by changing the description of the bug ) regards sadhu
        Hide
        Pradeep Soundararajan added a comment -

        Yes, I think we have to remove cloud-premium from the install.sh since it is not used:

        if [ "$installtype" == "q" -o "$installtype" == "Q" ] ; then
        true
        elif [ "$installtype" == "m" -o "$installtype" == "M" ] ; then
        echo "Installing the Management Server..." >&2
        doinstall cloud-client cloud-premium
        true
        elif [ "$installtype" == "a" -o "$installtype" == "A" ] ; then
        echo "Installing the Agent..." >&2
        if doinstall cloud-agent cloud-premium ; then
        echo "Agent installation is completed, please add the host from management server" >&2
        else
        true
        fi
        elif [ "$installtype" == "b" -o "$installtype" == "B" ] ; then
        echo "Installing the BareMetal Agent..." >&2
        doinstall cloud-baremetal-agent
        true
        elif [ "$installtype" == "s" -o "$installtype" == "S" ] ; then
        echo "Installing the Usage Server..." >&2
        doinstall cloud-usage cloud-premium
        true

        It has to be removed from the above lines. We don’t use the same for Citrix install.sh script.

        Can we compare the latest Citrix install.sh and merge the related only to ASF since the install.sh has been modified a lot over the period for Citrix.

        Thanks,
        Pradeep.S

        Show
        Pradeep Soundararajan added a comment - Yes, I think we have to remove cloud-premium from the install.sh since it is not used: if [ "$installtype" == "q" -o "$installtype" == "Q" ] ; then true elif [ "$installtype" == "m" -o "$installtype" == "M" ] ; then echo "Installing the Management Server..." >&2 doinstall cloud-client cloud-premium true elif [ "$installtype" == "a" -o "$installtype" == "A" ] ; then echo "Installing the Agent..." >&2 if doinstall cloud-agent cloud-premium ; then echo "Agent installation is completed, please add the host from management server" >&2 else true fi elif [ "$installtype" == "b" -o "$installtype" == "B" ] ; then echo "Installing the BareMetal Agent..." >&2 doinstall cloud-baremetal-agent true elif [ "$installtype" == "s" -o "$installtype" == "S" ] ; then echo "Installing the Usage Server..." >&2 doinstall cloud-usage cloud-premium true It has to be removed from the above lines. We don’t use the same for Citrix install.sh script. Can we compare the latest Citrix install.sh and merge the related only to ASF since the install.sh has been modified a lot over the period for Citrix. Thanks, Pradeep.S
        Hide
        Pradeep Soundararajan added a comment -

        I think we have remove cloud-premium from the install.sh since it is not used:

        if [ "$installtype" == "q" -o "$installtype" == "Q" ] ; then
        true
        elif [ "$installtype" == "m" -o "$installtype" == "M" ] ; then
        echo "Installing the Management Server..." >&2
        doinstall cloud-client cloud-premium
        true
        elif [ "$installtype" == "a" -o "$installtype" == "A" ] ; then
        echo "Installing the Agent..." >&2
        if doinstall cloud-agent cloud-premium ; then
        echo "Agent installation is completed, please add the host from management server" >&2
        else
        true
        fi
        elif [ "$installtype" == "b" -o "$installtype" == "B" ] ; then
        echo "Installing the BareMetal Agent..." >&2
        doinstall cloud-baremetal-agent
        true
        elif [ "$installtype" == "s" -o "$installtype" == "S" ] ; then
        echo "Installing the Usage Server..." >&2
        doinstall cloud-usage cloud-premium
        true

        It has to be removed from the above lines. We don’t use the same for Citrix install.sh script.

        Can we compare the latest Citrix install.sh and merge the related only to ASF since the install.sh has been modified a lot over the period for Citrix.

        Thanks,
        Pradeep.S

        Show
        Pradeep Soundararajan added a comment - I think we have remove cloud-premium from the install.sh since it is not used: if [ "$installtype" == "q" -o "$installtype" == "Q" ] ; then true elif [ "$installtype" == "m" -o "$installtype" == "M" ] ; then echo "Installing the Management Server..." >&2 doinstall cloud-client cloud-premium true elif [ "$installtype" == "a" -o "$installtype" == "A" ] ; then echo "Installing the Agent..." >&2 if doinstall cloud-agent cloud-premium ; then echo "Agent installation is completed, please add the host from management server" >&2 else true fi elif [ "$installtype" == "b" -o "$installtype" == "B" ] ; then echo "Installing the BareMetal Agent..." >&2 doinstall cloud-baremetal-agent true elif [ "$installtype" == "s" -o "$installtype" == "S" ] ; then echo "Installing the Usage Server..." >&2 doinstall cloud-usage cloud-premium true It has to be removed from the above lines. We don’t use the same for Citrix install.sh script. Can we compare the latest Citrix install.sh and merge the related only to ASF since the install.sh has been modified a lot over the period for Citrix. Thanks, Pradeep.S
        Hide
        sadhu suresh added a comment -

        Change the description as original bug has 2 issue and one issue become invlid and other issue need to be addressed.

        Show
        sadhu suresh added a comment - Change the description as original bug has 2 issue and one issue become invlid and other issue need to be addressed.
        Hide
        Pradeep Soundararajan added a comment -

        Sent the patch to fix this...

        Show
        Pradeep Soundararajan added a comment - Sent the patch to fix this...
        Hide
        Alex Huang added a comment -

        Commit id: 381c649

        Show
        Alex Huang added a comment - Commit id: 381c649
        Hide
        Pradeep Soundararajan added a comment -

        Today Oct 2nd is Holiday in India.

        Thanks,
        Pradeep.S

        Show
        Pradeep Soundararajan added a comment - Today Oct 2nd is Holiday in India. Thanks, Pradeep.S
        Hide
        Chip Childers added a comment -

        Closing issues that are still marked as resolved, but were part of the 4.0.0 release.

        Show
        Chip Childers added a comment - Closing issues that are still marked as resolved, but were part of the 4.0.0 release.

          People

          • Assignee:
            Pradeep Soundararajan
            Reporter:
            sadhu suresh
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development