Uploaded image for project: 'CloudStack'
  1. CloudStack
  2. CLOUDSTACK-10364

Inconsiste "setXXX" method names.

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • None
    • None
    • Security Level: Public (Anyone can view this level - this is the default.)
    • None

    Description

      The following two methods are named as "setXXX",
      actually, they are not setter but getter.
      Thus, they should be renamed as "getXXX".

       private String setVnetBrName(String pifName, String vnetId) {
              return "br" + pifName + "-" + vnetId;
          }
      
          private String setVxnetBrName(String pifName, String vnetId) {
              return "brvx-" + vnetId;
          }
      

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              BruceKuiLIU KuiLIU
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: