Click
  1. Click
  2. CLK-706

undeploy in tomcat prints warnings of thread local ContextStack

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.3.0-M1
    • Component/s: core
    • Labels:
      None
    • Environment:
      Tomcat 6.0.26

      Description

      With tomcat 6.0.26 on windows, starting the examples app, browse a page and press crtl-C in the tomcat window causes tomcat to complain about a possible memory leak:

      SEVERE: A web application created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@bf015]) and a value of type [org.apache.click.Context.ContextStack] (value [[]]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.

      It is caused by Context.hasThreadLocalContext() which creates an empty ContextStack if none existed before. Which is called by PerformanceFilter's attempt to find the application version number.

        Activity

        Finn Bock added a comment -

        fixed in trunk


          People

          • Assignee:
            Finn Bock
            Reporter:
            Finn Bock
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development