Click
  1. Click
  2. CLK-325

Compatibility issue from 1.4-RC2 to RC3

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Won't Fix
    • Affects Version/s: 1.4-RC3
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None
    • Environment:
      Kubuntu 7.10; Java 1.6.0_02; Groovy 1.5.4

      Description

      I encountered a problem when upgrading a project from 1.4-RC2 to RC3. On startup, the ClickServlet crashes with the following error message : "Can't find resource for bundle java.util.PropertyResourceBundle, key click-version". The error is caused by the statement at line 707 in class net.sf.click.util.ClickUtils. The statement obtains the property named "click-version" in file "click-control.properties". Normally, there wouldn't be anything wrong with this but since I had overridden the control property file for this perticular project and that the "click-version" key was not present in RC2, the servlet crashed. Of course, adding the line "click-version=1.4-RC3" in the file fixes the problem but it would be nice if this sort of issue did not arise anymore...

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        6d 21h 7m 1 Malcolm Edgar 06/Mar/08 05:54
        Henri Yandell made changes -
        Project Import Fri Mar 20 14:11:32 PDT 2009 [ 1237583492744 ]
        Malcolm Edgar made changes -
        Field Original Value New Value
        Resolution Won't Fix [ 2 ]
        Status Open [ 1 ] Closed [ 6 ]
        Malcolm Edgar added a comment -

        Hi Francois,

        Hopefully this issue will not occur again with future upgrades.

        regards Malcolm Edgar

        François-Xavier Guillemette created issue -

          People

          • Assignee:
            Malcolm Edgar
            Reporter:
            François-Xavier Guillemette
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development