Click
  1. Click
  2. CLK-146

ClickServlet uses getOutputStream

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None

      Description

      Hi

      I tried out MessAdmin http://messadmin.sourceforge.net/, a session monitoring tool. One of its features is the ability to inject html messages into specific/all sessions. The message will be displayed to the user as a popup, on the next interaction with the website. Apparently the problem is because ClickServlet uses response.getOutputStream() instead of response.getWriter(). This issue was raised before http://article.gmane.org/gmane.comp.web.click.user/354/. I will attach a patch which worked for me.

      However it could be that the getOutpuStream() was used for good reason?

      regards

      bob

        Activity

        Malcolm Edgar added a comment -

        Applied patch looks good, haven't seen any issues with testing. Checked in will be available in release 1.1

        regards Malcolm


          People

          • Assignee:
            Malcolm Edgar
            Reporter:
            Bob Schellink
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development