Commons CLI
  1. Commons CLI
  2. CLI-129

CLI_1_BRANCH build.xml doesn't work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.1
    • Component/s: CLI-1.x
    • Labels:
      None
    • Environment:

      Ant 1.6.5

      Description

      This file was apparently created half-way through the CLI-2 branch. I removed the second 'jar' task, and fix up a couple other.

      1. AllTestSuite.java
        2 kB
        Brian Egge
      2. build.xml.patch
        4 kB
        Brian Egge

        Activity

        Show
        Brian Egge added a comment - Patch for http://svn.apache.org/repos/asf/jakarta/commons/proper/cli/branches/CLI_1_BRANCH/build.xml
        Hide
        Brian Egge added a comment -

        Test suite which runs all tests. Useful for IDEs.

        Show
        Brian Egge added a comment - Test suite which runs all tests. Useful for IDEs.
        Hide
        Henri Yandell added a comment -

        Good place to start

        The build.xml is fixed. I used your patch as a pointer for the parts of project.xml that needed fixing and then ran maven ant.

        For the IDE bit, the only IDE I've used recently is Eclipse, but there you can right click on src/tests/ and select Run as JUnit Test and it will run all the tests in that directory. Presumably IDEA and Netbeans are the same?

        Show
        Henri Yandell added a comment - Good place to start The build.xml is fixed. I used your patch as a pointer for the parts of project.xml that needed fixing and then ran maven ant. For the IDE bit, the only IDE I've used recently is Eclipse, but there you can right click on src/tests/ and select Run as JUnit Test and it will run all the tests in that directory. Presumably IDEA and Netbeans are the same?
        Hide
        Brian Egge added a comment -

        In this case, the AllTestSuites doesn't add a lot of value. In other projects I frequently have integration/acceptance tests, which extends from TestCase, but which I don't want to execute with the unit tests. Since this project only has unit tests, the 'Run all tests in directory' option works just fine.

        Show
        Brian Egge added a comment - In this case, the AllTestSuites doesn't add a lot of value. In other projects I frequently have integration/acceptance tests, which extends from TestCase, but which I don't want to execute with the unit tests. Since this project only has unit tests, the 'Run all tests in directory' option works just fine.
        Hide
        Brian Egge added a comment -

        Commit r538025 by bayard fixed this issue.

        Show
        Brian Egge added a comment - Commit r538025 by bayard fixed this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Brian Egge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development