Uploaded image for project: 'Chukwa'
  1. Chukwa
  2. CHUKWA-729

Downgade solr version to work with JDK 6

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.6.0
    • Fix Version/s: 0.6.0
    • Component/s: Build and Test Code
    • Labels:
      None

      Description

      Hadoop 1.x works best with JDK 6. Solr 4.9.0 was compiled for JDK 7. There can be potentially mismatch, if the runtime JDK is version 6. Therefore, we need to move Solr to 4.7.2 which is the last known version that works with JDK 6.

        Activity

        Hide
        eyang Eric Yang added a comment -

        I just committed this.

        Show
        eyang Eric Yang added a comment - I just committed this.
        Hide
        hudson Hudson added a comment -

        FAILURE: Integrated in Chukwa-trunk #514 (See https://builds.apache.org/job/Chukwa-trunk/514/)
        CHUKWA-729. Downgrade solr version for JDK 6 support. (Eric Yang) (eyang: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1620078)

        • /chukwa/trunk/CHANGES.txt
        • /chukwa/trunk/pom.xml
        Show
        hudson Hudson added a comment - FAILURE: Integrated in Chukwa-trunk #514 (See https://builds.apache.org/job/Chukwa-trunk/514/ ) CHUKWA-729 . Downgrade solr version for JDK 6 support. (Eric Yang) (eyang: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1620078 ) /chukwa/trunk/CHANGES.txt /chukwa/trunk/pom.xml

          People

          • Assignee:
            eyang Eric Yang
            Reporter:
            eyang Eric Yang
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development