Uploaded image for project: 'Chukwa'
  1. Chukwa
  2. CHUKWA-716

Frequent unit test failures org.apache.hadoop.chukwa.inputtools.TestInputFormat.testInputFormatIllegalRegex

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.6.0
    • Fix Version/s: 0.6.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu Linux + Java 6.

      Description

      Frequent test case failure in Jenkins.

      Test case 1:

      org.apache.hadoop.chukwa.inputtools.TestInputFormat.testInputFormatIllegalRegex

      Failing for the past 1 build (Since Failed#491 )
      Took 0.5 sec.
      Error Message

      IO exception java.io.FileNotFoundException: File file:/tmp/tmpSeqFile does not exist.
      Stacktrace

      junit.framework.AssertionFailedError: IO exception java.io.FileNotFoundException: File file:/tmp/tmpSeqFile does not exist.
      at junit.framework.Assert.fail(Assert.java:50)
      at org.apache.hadoop.chukwa.inputtools.TestInputFormat.testInputFormatIllegalRegex(TestInputFormat.java:105)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at junit.framework.TestCase.runTest(TestCase.java:168)
      at junit.framework.TestCase.runBare(TestCase.java:134)
      at junit.framework.TestResult$1.protect(TestResult.java:110)
      at junit.framework.TestResult.runProtected(TestResult.java:128)
      at junit.framework.TestResult.run(TestResult.java:113)
      at junit.framework.TestCase.run(TestCase.java:124)
      at junit.framework.TestSuite.runTest(TestSuite.java:243)
      at junit.framework.TestSuite.run(TestSuite.java:238)
      at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:83)
      at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:53)
      at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:123)
      at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:104)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at org.apache.maven.surefire.util.ReflectionUtils.invokeMethodWithArray(ReflectionUtils.java:164)
      at org.apache.maven.surefire.booter.ProviderFactory$ProviderProxy.invoke(ProviderFactory.java:110)
      at org.apache.maven.surefire.booter.SurefireStarter.invokeProvider(SurefireStarter.java:175)
      at org.apache.maven.surefire.booter.SurefireStarter.runSuitesInProcessWhenForked(SurefireStarter.java:81)
      at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:68)

      1. CHUKWA-716.patch
        10 kB
        Eric Yang
      2. CHUKWA-716.2.patch
        4 kB
        Eric Yang

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Chukwa-trunk #497 (See https://builds.apache.org/job/Chukwa-trunk/497/)
        CHUKWA-716. Fixed undefined System Properties for test cases and test case dependency. (Eric Yang) (eyang: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1611855)

        • /chukwa/trunk/src/test/java/org/apache/hadoop/chukwa/analysis/salsa/fsm/TestFSMBuilder.java
        • /chukwa/trunk/src/test/java/org/apache/hadoop/chukwa/extraction/demux/TestDemux.java
        eyang Eric Yang added a comment -

        Fixed FSM and Demux test cases.

        eyang Eric Yang added a comment -

        Updated test case to clean up hdfs directory between test.

        eyang Eric Yang added a comment -

        Integration test is failing due to previous test case already used dfs directory, and prevent mini cluster to be started again.

        hudson Hudson added a comment -

        FAILURE: Integrated in Chukwa-trunk #496 (See https://builds.apache.org/job/Chukwa-trunk/496/)
        CHUKWA-716. Fixed undefined System Properties for test cases and test case dependency. (Eric Yang) (eyang: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1610779)

        • /chukwa/trunk/CHANGES.txt
        • /chukwa/trunk/pom.xml
        • /chukwa/trunk/src/test/java/org/apache/hadoop/chukwa/inputtools/TestInputFormat.java
        eyang Eric Yang added a comment -

        I just committed this.

        eyang Eric Yang added a comment -

        Fixed test case or run in linear order, and also fixed undefined system variable for test cases.

        eyang Eric Yang added a comment -

        The root cause is testInputFormatIllegalRegex depends on output of testInputFormat. There is no guarantee of test orders. Unit test dependency is not recommended by Junit test. The test cases need to be rewritten into two independent test cases.


          People

          • Assignee:
            eyang Eric Yang
            Reporter:
            eyang Eric Yang
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development