Looks good to me too although I'd like to request one more small change. In TestChukwaWriters you re-use the "testChukwaWriters_JB_" directory prefix used in the test data. Can you change that to something that implies the test name, so its content can be mapped to the test. Something like "testChukwaWriters_testSeqWriterFixedCloseInterval_".
I'm not sure how the "JB" convention was introduced in the pre-existing test in that class (maybe Jerome's initials?), but you might a well correct that in the other test as well (i.e. "testChukwaWriters_testWriter_").