Uploaded image for project: 'Chukwa'
  1. Chukwa
  2. CHUKWA-587

The logic to load the front page of hicc appears to be broken

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.5.0
    • Component/s: User Interface
    • Labels:
      None
    • Environment:

      A stand alone server with all components

    • Release Note:
      Improved default cluster selection code.

      Description

      I get the following error, in spite of running hicc, collector, agents etc continuously for more than 5 days.

      This appears only when I access : http://localhost:4080/hicc URL. Note that the URL : http://localhost:4080/hicc/jsp/graph_explorer.jsp appears to work okay for me.

      HTTP ERROR: 500

      INTERNAL_SERVER_ERROR

      RequestURI=/hicc/
      Caused by:

      java.util.NoSuchElementException
      at java.util.HashMap$HashIterator.nextEntry(HashMap.java:796)
      at java.util.HashMap$KeyIterator.next(HashMap.java:828)
      at org.apache.jsp.index_jsp._jspService(org.apache.jsp.index_jsp:100)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:93)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:373)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:470)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:364)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
      at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:285)
      at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:126)
      at org.mortbay.jetty.servlet.DefaultServlet.doGet(DefaultServlet.java:463)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:513)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
      at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

      We will need to give a consistent behavior for the front page, so that we don't end up giving an opinion that HICC is not working. There may be a change required in the way, chukwa hicc loads the front index.jsp by reading the hbase tables.

      Regards, DKN

        Activity

        eyang Eric Yang added a comment -

        I am speculating that user session has expired, but the index.jsp is not handling expired session correctly.

        ndevapra DKN added a comment -

        Hi Eric, It doesn't appear to be a problem with the session, as it appears the first time I login. Even if I close all browsers and freshly open a session, this index page is not loaded. It gives the feeling to the end user that nothing is working .. hence is an important defect to fix.

        With HBase providing search facility with Solr, the strategic direction that chukwa is taking looks promising.

        Cheers, DKN

        eyang Eric Yang added a comment -

        The described exception is caused by not having any cluster tag in SystemMetrics hbase table in the past hour. For making HICC a generic data analytics and reporting system, setting a default cluster in the user session should be optional.

        eyang Eric Yang added a comment -

        Make cluster setup optional.

        ndevapra DKN added a comment -

        Thanks for fixing this Eric. I am now able to login to HICC using a remote system (the earlier jetty fix ) and also load the front page without errors.

        I will create few other defects, so that we have the schemas displayed out of the box correctly.

        Cheers, DKN


          People

          • Assignee:
            eyang Eric Yang
            Reporter:
            ndevapra DKN
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development