Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.4.0
    • Component/s: Build and Test Code
    • Labels:
      None
    • Environment:

      Redhat EL 5.1, Java 6.

      Description

      Gearing toward 0.4.0 release. A couple reported test case fails:

      From Ari:

      ...
      [junit] Test org.apache.hadoop.chukwa.rest.resource.TestViewResource FAILED
      [junit] Running org.apache.hadoop.chukwa.rest.resource.TestWidgetResource
      [junit] Tests run: 2, Failures: 0, Errors: 1, Time elapsed: 4.969 sec
      [junit] 2010-02-22 12:22:57.748::INFO: Shutdown hook executing
      [junit] 2010-02-22 12:22:57.748::INFO: Graceful shutdown
      SelectChannelConnector@0.0.0.0:8080
      [junit] 2010-02-22 12:22:57.749::INFO: Graceful shutdown
      org.mortbay.jetty.webapp.WebAppContext@6e75d758

      {/hicc,jar:file:/Users/asrabkin/apache_foundation/chukwa-trunk/build/test/classes/webapps/hicc.war!/}

      [junit] 2010-02-22 12:22:58.891::INFO: Shutdown hook complete
      [junit] Test
      org.apache.hadoop.chukwa.rest.resource.TestWidgetResource FAILED
      [junit] Running
      org.apache.hadoop.chukwa.tools.backfilling.TestBackfillingLoader
      [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 77.251 sec
      [junit] Running org.apache.hadoop.chukwa.util.TestCRValidator
      [junit] Tests run: 3, Failures: 0, Errors: 0, Time elapsed: 0.656 sec.

      From Bill:

      Testsuite: org.apache.hadoop.chukwa.dataloader.TestSocketDataLoader
      Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 0.435 sec

      ------------- Standard Output ---------------
      pipeline established; now pushing a chunk
      ------------- ---------------- ---------------
      Testcase:
      testSocketTee(org.apache.hadoop.chukwa.dataloader.TestSocketDataLoader):
      FAILED
      expected:<a> but was:<[B@2353f67e>
      junit.framework.AssertionFailedError: expected:<a> but was:<[B@2353f67e>
      at
      org.apache.hadoop.chukwa.dataloader.TestSocketDataLoader.testSocketTee(TestSocketDataLoader.java:63)

        Activity

        Eric Yang added a comment -

        Failed test cases from Ari.

        Ari Rabkin added a comment -

        This is a blocker for releasing 0.4. It may be the only blocker, at this point.

        Eric Yang added a comment -

        Fix for test sock data loader unit test. I can't reproduce Ari's problem in both MacOSX and Linux.

        Ari Rabkin added a comment -

        +1 to patch.

        Eric Yang added a comment -

        hudson is stuck on having bad data in /tmp/chukwa/hicc. A clean up fix should do the trick.

        Eric Yang added a comment -

        I just committed this to TRUNK and 0.4 branch.

        Hudson added a comment -

        Integrated in Chukwa-trunk #330 (See http://hudson.zones.apache.org/hudson/job/Chukwa-trunk/330/)
        . Remove /tmp/chukwa/hicc during test phase to prevent bad data building up and prevent test case to run properly. (Eric Yang)
        . Remove /tmp/chukwa/hicc during test phase to prevent bad data building up and prevent test case to run properly. (Eric Yang)


          People

          • Assignee:
            Eric Yang
            Reporter:
            Eric Yang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development