Right now, the chukwa logs are fairly inconsistent in nomenclature. This patch addresses this.
A major change in this patch is that adaptor names all start with adaptor_. This property is enforced at adaptor creation time – if an adaptor name lacks that prefix, it is added.
The main motive for this change was to make the logs easier to read and parse. It is also more consistent with the style of Hadoop identifiers.
While uniformity is good, we should be consistent in using pascal case or camel case.
My vote is to use pascal case for shell script, and camel case for java. What do you think?
Eric, I'm not quite sure I understand the context of your comment. Pascal or Camel case for what?
The logic of using "adaptor_" as a marker for adaptor IDs is that it's consistent with the way Hadoop marks its identifiers – it looks like "job_" and "task_" and so forth.
I misunderstood what you tried to accomplish. I thought this change applies to adaptor type which was also referred by adaptor name in the past. The change makes sense. +1.
I just committed this.
Should update documentation to explain this.
Revise documentation. Correct a typo in the code.
I will commit this tomorrow, barring objection. It's a small change, with no functional implications.
Integrated in Chukwa-trunk #216 (See http://hudson.zones.apache.org/hudson/job/Chukwa-trunk/216/)
Just committed this fix. (Forgot to document it in commit message, though. )
want to do more revisions
Add a "post ID" to help link together various messages about a particular HTTP post.
It's small changes to logging, so I will commit within a few days, barring objection.
Integrated in Chukwa-trunk #225 (See http://hudson.zones.apache.org/hudson/job/Chukwa-trunk/225/)
. More logging enhancement