Uploaded image for project: 'Chukwa'
  1. Chukwa
  2. CHUKWA-41

ChukwaLog4jAppender does not escape \n for exception

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    1. CHUKWA-41.patch
      2 kB
      Jerome Boulon

      Activity

      asrabkin Ari Rabkin added a comment -

      I just committed this. Thanks, Jerome!

      jboulon Jerome Boulon added a comment -

      out.info("test 1", new RuntimeException("my long exception \n line2", new IOException("in IO exception")));
      out.info("test 2");
      out.info("test 3 with \n a new line here");

      Output:

      2009-03-25 11:16:14,803 INFO main Test1 - test 1^D
      java.lang.RuntimeException: my long exception ^D
      line2^D
      at Test1.main(Test1.java:17)^D
      Caused by: java.io.IOException: in IO exception^D
      ... 1 more
      2009-03-25 11:16:14,827 INFO main Test1 - test 2
      2009-03-25 11:16:14,827 INFO main Test1 - test 3 with ^D
      a new line here


        People

        • Assignee:
          jboulon Jerome Boulon
          Reporter:
          jboulon Jerome Boulon
        • Votes:
          0 Vote for this issue
          Watchers:
          3 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development