Uploaded image for project: 'Chukwa'
  1. Chukwa
  2. CHUKWA-328

NPE for empty chukwarecord sequence file

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.2.0
    • Fix Version/s: 0.2.0, 0.3.0
    • Component/s: None
    • Labels:
      None

      Description

      2009-06-23 17:21:44,307 ERROR main MetricDataLoaderPool - java.util.concurrent.ExecutionException: java.lang.NullPointerException
      at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
      at java.util.concurrent.FutureTask.get(FutureTask.java:83)
      at org.apache.hadoop.chukwa.dataloader.MetricDataLoaderPool.load(MetricDataLoaderPool.java:49)
      at org.apache.hadoop.chukwa.extraction.demux.PostProcessorManager.processDemuxPigOutput(PostProcessorManager.java:188)
      at org.apache.hadoop.chukwa.extraction.demux.PostProcessorManager.start(PostProcessorManager.java:145)
      at org.apache.hadoop.chukwa.extraction.demux.PostProcessorManager.main(PostProcessorManager.java:80)
      Caused by: java.lang.NullPointerException
      at org.apache.hadoop.chukwa.extraction.engine.ChukwaRecord.getValue(ChukwaRecord.java:46)
      at org.apache.hadoop.chukwa.extraction.engine.RecordUtil.getClusterName(RecordUtil.java:14)
      at org.apache.hadoop.chukwa.dataloader.MetricDataLoader.run(MetricDataLoader.java:518)
      at org.apache.hadoop.chukwa.dataloader.MetricDataLoader.call(MetricDataLoader.java:567)
      at org.apache.hadoop.chukwa.dataloader.MetricDataLoader.call(MetricDataLoader.java:50)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)

      The root cause is that we should not use the ChukwaRecord if there is no record in the file.

        Activity

        eyang Eric Yang added a comment -

        I just committed this, thanks Cheng.

        eyang Eric Yang added a comment -

        +1 Looks good.

        zhangyongjiang Cheng added a comment -

        patch provided.


          People

          • Assignee:
            zhangyongjiang Cheng
            Reporter:
            zhangyongjiang Cheng
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development