Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.2.0
    • Fix Version/s: 0.2.0
    • Component/s: User Interface
    • Labels:
      None
    • Environment:

      Redhat EL 5.1, Java 6

      Description

      When click on Dashboard builder, it shows this exception:

      HTTP Status 500 -

      type Exception report

      message

      description The server encountered an internal error () that prevented it from fulfilling this request.

      exception

      org.apache.jasper.JasperException: Unable to compile class for JSP:

      An error occurred at line: 121 in the jsp file: /jsp/workspace/manage_view.jsp
      The method setTest(boolean) in the type WhenTag is not applicable for the arguments (String)
      118: </td>
      119: <td nowrap width="60">
      120: <c:choose>
      121: <c:when test="$

      {key}!=${default_view}">
      122: <input class="formButton" name="setDefault" value="Set As Default" type="button" onClick="setDefaultView('${key}

      ');"/>
      123: </c:when>
      124: <c:otherwise>

      Stacktrace:
      org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92)
      org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
      org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:439)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:334)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:312)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:299)
      org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:586)
      org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317)
      org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
      org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

      note The full stack trace of the root cause is available in the Apache Tomcat/6.0.20 logs.

      This regression is trigger by jsp library upgrade.

        Activity

        hudson Hudson added a comment -

        Integrated in Chukwa-trunk #55 (See http://hudson.zones.apache.org/hudson/job/Chukwa-trunk/55/)
        . Fix jsp syntax error. (Terence Kwan via Eric Yang)

        eyang Eric Yang added a comment -

        I just committed this to both trunk and 0.2 branch.
        First chukwa 0.2 testing deployment is working.

        Thanks Terence for the quick fix.

        terencekwan Terence Kwan added a comment -

        test it on the system and it is working. +1

        asrabkin Ari Rabkin added a comment -

        +1 as far as I'm concerned.

        eyang Eric Yang added a comment -

        Patch to update JSP syntax.


          People

          • Assignee:
            eyang Eric Yang
            Reporter:
            eyang Eric Yang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development