Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.1.2
    • Fix Version/s: 0.1.2
    • Component/s: Data Processors
    • Labels:
      None
    • Environment:

      Redhat 5.1, Java 6

      Description

      Aggregation has dependency of running aggregation relative to the current time. We need a set of tools to create partition and compute SQL aggregation manually.

      1. CHUKWA-128-1.patch
        6 kB
        Eric Yang
      2. CHUKWA-128.patch
        6 kB
        Eric Yang

        Issue Links

          Activity

          eyang Eric Yang added a comment -

          I just committed this, thanks Cheng.

          zhangyongjiang Cheng added a comment -

          +1 looks good to me.

          eyang Eric Yang added a comment -

          Yes, when there are no parameter passed in, we want to aggregate once for the current time.

          zhangyongjiang Cheng added a comment -

          In main method, if args.length < 4, variable endTime will equal 0. Since startTime is set to 0. the while loop block will be executed once. Is it expected behavior?

          eyang Eric Yang added a comment -

          Regenerate patch. Previous patch was not generated correctly.

          eyang Eric Yang added a comment -

          Tools to manually load sequence file to database, and aggregate.


            People

            • Assignee:
              eyang Eric Yang
              Reporter:
              eyang Eric Yang
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development