Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-9771

Installation of plugins' dependencies does not work

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.3.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Linux 15.04, Cordova from the cordova-ubuntu PPA

      Description

      The mechanism for declaring plugin's dependencies is convoluted and currently broken. The only plugin using it is the facebookconnect plugin, which is still not merged upstream, and which doesn't successfully manage to install its dependencies.
      Instead of asking plugins to install yet another JSON file using non conventional elements in plugin.xml, we should just use the <config-file> element and let plugins declare dependencies with that.

        Attachments

          Activity

            People

            • Assignee:
              zaspire Maxim Ermilov
              Reporter:
              mardy Alberto Mardegan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: