Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-9010

Update check_reqs to include explanation for how to get SDK

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      If you install BlackBerry WebWorks, cordova-blackberry bundles the portions of the bb10 sdk necessary to build/deploy blackberry 10 packages.

      If you use Cordova directly and add cordova-blackberry, you somehow have to get those files into your path.

      One way is by downloading Momentics (which is huge), and using it to download a BB10 NDK (which is bigger than that), and then running:

      {path-to-momentics}

      /bbndk-env_10_.
      – where the the first * includes a version, that could be 0_10_buildid, or 1_0_pat or 2_0_buildid or 3_0_buildid (there are other values than 0 for the release number) and the second * is sh/bat depending on your platform.

      This isn't really the way we want to do it. But, we definitely need to have check_reqs offer better support.

        Attachments

          Activity

            People

            • Assignee:
              jsoref Josh Soref
              Reporter:
              jsoref Josh Soref
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: