Apache Cordova
  1. Apache Cordova
  2. CB-648

AutoHideSplashScreen not working for iPad but working correctly for iPhone

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Not A Problem
    • Affects Version/s: 1.7.0
    • Fix Version/s: None
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      XCode with Simulator and Devices

      Description

      Setting AutoHideSplashScreen to NO in Cordova.plist is not respected by iPad (Simulator and Device) but works correctly for iPhone (Simulator and Device).

      How to reproduce (working - iPhone):

      • Set AutoHideSplashScreen to NO in Cordova.plist and start app.
      • Splash stays forever
      • Thats OK

      How to reproduce (not working - iPad):

      • Set AutoHideSplashScreen to NO in Cordova.plist and start app.
      • Splash is removed
      • Should stay forever

      It's a huge problem for me, because I need to prepare data and apply styles before showing the first page.

      1. no_image_specified.png
        292 kB
        Shazron Abdullah

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 11h 25m 1 Shazron Abdullah 09/May/12 22:00
        Shazron Abdullah made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Not A Problem [ 8 ]
        Shazron Abdullah made changes -
        Attachment no_image_specified.png [ 12526222 ]
        Shazron Abdullah added a comment -

        See attached image (Launch Images section). A new project does not have default iPad images included, you will have to add them to your project yourself according to the dimensions required.

        Andreas Rami made changes -
        Field Original Value New Value
        Priority Critical [ 2 ] Blocker [ 1 ]
        Andreas Rami created issue -

          People

          • Assignee:
            Shazron Abdullah
            Reporter:
            Andreas Rami
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development