Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.0
    • Fix Version/s: 2.1.0
    • Component/s: WP7 (defunct)
    • Labels:
      None

      Description

      This is not working since 1.6 I think.

      The problem is that the function getDuration is not called anymore from JS

      Media.prototype.getDuration = function()

      { return this._duration; }

      ;

      and it is not set correctly

        Activity

        Dan Ardelean added a comment -

        The problem is here:
        module.exports = function(args)

        { console.log("media on status :: " + args); var res = JSON.parse(args); require("cordova/media").onStatus(res.id, res.msg, res.value); }

        ;
        });

        onStatus is never clled so the duration is not set

        Dan Ardelean added a comment -

        Changing it to:
        var res = JSON.parse(args);
        Media.onStatus(res.id, res.msg, res.value);

        it starts working


          People

          • Assignee:
            Herm Wong
            Reporter:
            Dan Ardelean
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2h
              2h
              Remaining:
              Remaining Estimate - 2h
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development