Apache Cordova
  1. Apache Cordova
  2. CB-505

Document iOS quirks for lifecycle events and specific "resign" and "active" events

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Master
    • Fix Version/s: 1.6.1
    • Component/s: Docs
    • Labels:
      None

      Description

      This has been there for a long time but not doc'ed.
      Also see quirks: http://shazronatadobe.wordpress.com/2012/03/14/apache-cordova-lifecycle-events-in-ios-4-versus-ios-5/

        Activity

        Randy McMillan added a comment -

        lifecycle events are causing issues in plugins as well.

        It may be useful to list all states that plugins "should" support in the plugin docs.

        Maybe create a plugin template?

        Shazron Abdullah added a comment -

        Please elaborate on these plugin issues with lifecycle events.

        Plugin template is prob not in the radar - maybe it will after/on 2.0 when plugin packaging will be finalized.

        Randy McMillan added a comment -

        The issue can be reproduced using the CalendarPlugin project here: https://github.com/RandyMcMillan/SampleApps

        When app runs in background then manually killed from the springboard it blacks out the screen.

        Randy McMillan added a comment - - edited

        Correction...it may not be isolated to this plugin. It may be associated with the project and I thought it was isolated to this plugin. I just created a generic project with no mods from the template and it exists. (oops)

        Shazron Abdullah added a comment -

        All CDVPlugins have access to these events: https://github.com/apache/incubator-cordova-ios/blob/master/CordovaLib/Classes/CDVPlugin.m#L50 and need to enable them if they choose to (I agree, it should be documented but these are more iOS events that any dev can find out, nothing specific to Cordova)

        Randy McMillan added a comment -

        Reproduced issue youtube video: http://www.youtube.com/watch?v=j8brmcO8CtQ

        Randy McMillan added a comment -

        Gotcha...I didn't realize that it wasn't specific to Cordova..thanks.

        Shazron Abdullah added a comment -

        Thanks for the video. This might be because Xcode is still attached to the app instance. Try again while the app is not tethered to Xcode (ie launched from Xcode).


          People

          • Assignee:
            Shazron Abdullah
            Reporter:
            Shazron Abdullah
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development