Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.5.0
    • Fix Version/s: None
    • Component/s: Android, CordovaJS
    • Labels:
      None
    • Environment:

      Sony Xperia Tablet Z

      Description

      On Sony Xperia Tablet Z, playing audio would crash after 2-3 seconds of playback. Here is the error log I get from the console:

      04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
      04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
      04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1)

      I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

      Here is my javascript code

       
      function playAudio(src) {
       if(my_media){ stopAudio(); }
        my_media = new Media(src, onSuccess, onError);
        my_media.play();
       }
      }
      
      function stopAudio() {
        my_media.stop();
        my_media.release();
        my_media = null;
      }
      

        Activity

        James Wong created issue -
        James Wong made changes -
        Field Original Value New Value
        Description On Sony Xperia Tablet Z, playAudio would crash after 2-3 seconds of playback. Here is the error log I get from the console:
        {quote}
        04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
        04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
        {color:red} 04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1){color}
        {quote}

        I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

        Here is my javascript code

        {quote}
        function playAudio(src) {
         if(my_media){ stopAudio(); }
          my_media = new Media(src, onSuccess, onError);
          my_media.play();
         }
        }

        function stopAudio() {
         if (my_media) {
          my_media.stop();
          my_media.release();
          my_media = null;
         }
        }
        {quote}
         
        On Sony Xperia Tablet Z, playAudio would crash after 2-3 seconds of playback. Here is the error log I get from the console:
        {quote}
        04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
        04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
        {color:red} 04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1){color}
        {quote}

        I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

        Here is my javascript code

        {noformat}
        function playAudio(src) {
         if(my_media){ stopAudio(); }
          my_media = new Media(src, onSuccess, onError);
          my_media.play();
         }
        }

        function stopAudio() {
         if (my_media) {
          my_media.stop();
          my_media.release();
          my_media = null;
         }
        }
        {noformat}
         
        James Wong made changes -
        Description On Sony Xperia Tablet Z, playAudio would crash after 2-3 seconds of playback. Here is the error log I get from the console:
        {quote}
        04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
        04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
        {color:red} 04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1){color}
        {quote}

        I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

        Here is my javascript code

        {noformat}
        function playAudio(src) {
         if(my_media){ stopAudio(); }
          my_media = new Media(src, onSuccess, onError);
          my_media.play();
         }
        }

        function stopAudio() {
         if (my_media) {
          my_media.stop();
          my_media.release();
          my_media = null;
         }
        }
        {noformat}
         
        On Sony Xperia Tablet Z, playAudio would crash after 2-3 seconds of playback. Here is the error log I get from the console:
        {quote}
        04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
        04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
        {color:red} 04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1){color}
        {quote}

        I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

        Here is my javascript code

        {noformat}
        function playAudio(src) {
         if(my_media){ stopAudio(); }
          my_media = new Media(src, onSuccess, onError);
          my_media.play();
         }
        }

        function stopAudio() {
          my_media.stop();
          my_media.release();
          my_media = null;
        }
        {noformat}
         
        James Wong made changes -
        Description On Sony Xperia Tablet Z, playAudio would crash after 2-3 seconds of playback. Here is the error log I get from the console:
        {quote}
        04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
        04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
        {color:red} 04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1){color}
        {quote}

        I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

        Here is my javascript code

        {noformat}
        function playAudio(src) {
         if(my_media){ stopAudio(); }
          my_media = new Media(src, onSuccess, onError);
          my_media.play();
         }
        }

        function stopAudio() {
          my_media.stop();
          my_media.release();
          my_media = null;
        }
        {noformat}
         
        On Sony Xperia Tablet Z, playing audio would crash after 2-3 seconds of playback. Here is the error log I get from the console:
        {quote}
        04-07 17:34:01.220: D/dalvikvm(14639): GC_CONCURRENT freed 64K, 2% free 11807K/12039K, paused 1ms+2ms
        04-07 17:34:03.230: D/AudioPlayer(14639): Send a onStatus update for the new seek
        {color:red} 04-07 17:34:03.610: A/libc(14639): Fatal signal 11 (SIGSEGV) at 0x00000016 (code=1){color}
        {quote}

        I tried 2 versions of MP3 (48kbps and 128kbps) files but it would still crash.

        Here is my javascript code

        {noformat}
        function playAudio(src) {
         if(my_media){ stopAudio(); }
          my_media = new Media(src, onSuccess, onError);
          my_media.play();
         }
        }

        function stopAudio() {
          my_media.stop();
          my_media.release();
          my_media = null;
        }
        {noformat}
         
        Joe Bowser added a comment -

        James Wong I need more info, such as where the files were stored. Can you provide me with a slightly more fleshed out example here? Also, is this only on the Sony Xperia Z Tablet?

        Joe Bowser added a comment -

        If you can provide more information, we'll be happy to re-open this issue. We can't let critical issues stay open if we can't reproduce them. Sorry!

        Joe Bowser made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Joe Bowser
            Reporter:
            James Wong
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development