Apache Cordova
  1. Apache Cordova
  2. CB-193

Android camera bug, caused by out of memory error?

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.3.0
    • Fix Version/s: None
    • Component/s: Android
    • Labels:
    • Environment:

      Android

      Description

      We have a guy on our support forms who has been running into issues with the android camera. I am going to paste some of his findings below.

      We've done a bunch of testing, and it looks like the problem is not specifically with the Droid X, but rather with how PhoneGap handles memory management for the Camera API.

      If lots of other apps are running, then the app restarts after the camera API is called, a picture taken, and "saved". If only a few apps are running (i.e. there is more free memory), then the camera API works as designed and the user is returned to the app after taking and saving the picture.

      The Android Camera issues are becoming a show-stopper for us. We've tried installing the latest nightly builds that supposedly fix the problems, but Phonegap still crashes on a Droid when taking a picture.

      This problem is not at all isolated to us. For now, it seems that Phonegap is unusable as an app platform for Android if the camera is involved.

      Are there any plans to escalate this issue so Android Apps using the camera can be deployed?

      Here's how widespread this issue is:

      https://groups.google.com/group/phonegap/browse_thread/thread/e084f...#
      https://groups.google.com/group/phonegap/browse_thread/thread/b0029...#
      https://github.com/callback/phonegap/issues/5
      https://github.com/callback/callback-android/issues/31
      https://issues.apache.org/jira/browse/CB-14
      https://groups.google.com/group/phonegap/browse_thread/thread/beaa5...
      https://groups.google.com/group/phonegap/browse_thread/thread/185c2...
      https://groups.google.com/group/phonegap/browse_thread/thread/1174e...

      Seems like he is having the issue mainly with Droid X (Android 2.3)

      I will send him this link and get him to come give more details on the issue.

        Activity

        Chip Matthes added a comment -

        When the Droid X camera is used in our Phonegap app, approximately two thirds of the time, the app restarts after the uses presses the Save button on the camera. Note that we don't have this problem if the photo is retrieved from the gallery and we don't have the problem when with test with a Samsung Galaxy S.

        We've tried many things to fix the problem, none have worked.
        1) We save to file, not to memory
        2) We lowered the photo quality to 25
        3) We've upgraded to Phonegap 1.3 and even to newer, unreleased versions that include some specific Android camera fixes (including a patch that includes this fix: https://github.com/callback/callback-android/commit/fae551f0cea22c9843911cdcc2472b4e8135c93d)

        Chip Matthes added a comment -

        Couple of additional notes:

        1) Upgraded to PhoneGap 1.4 and problem persists
        2) Can replicate it on a second Droid X, so the issue is not with the specific handset

        Joe Bowser added a comment -

        Duplicate of CB-14, as linked in the ticket.


          People

          • Assignee:
            Unassigned
            Reporter:
            Steve Gill
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development