Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.0
    • Fix Version/s: None
    • Component/s: Android
    • Labels:
    • Environment:

      any android device

      Description

      window.locaton.replace doesn't seem to update the history. I have a javascript page that depends on replacing the history when certain filters are selected, without actually causing the page to reload, using window.locaton.replace.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        38m 22s 1 Joe Bowser 06/Nov/12 23:05
        Adam added a comment - - edited

        I've since moved to localStorage for those items, but will give it a try post-project. What does that preference do exactly? It was set to false, since I upgraded to 2.2.0, but window.history was still working for me. Just wondering because I didn't see it in the docs and not much help on the forums...

        Andrew Grieve added a comment -

        Also of note is the useBrowserHistory setting in config.xml. The default was changed to true in 2.2. I'm not sure if it would affect this case, but worth a try.

        Adam added a comment -

        Ok, thanks, Joe. My app has a lot of moving parts, so I will try to provide a simplified sample to recreate when I have a chance.

        Joe Bowser made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Joe Bowser added a comment -

        window.location.replace does seem to update the history on this end. Tested on Galaxy Nexus (4.1.2), Nexus S (2.3.6) and Samsung Galaxy S2 (4.0.3)

        Adam created issue -

          People

          • Assignee:
            Joe Bowser
            Reporter:
            Adam
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development