Apache Cordova
  1. Apache Cordova
  2. CB-171

Changing the language on the phone when the app is running in background causes a crash

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3.0
    • Fix Version/s: None
    • Component/s: Android
    • Labels:
      None

      Description

      I'm seeing an issue where if I change the language of the phone when
      the app is running in the background - the subsequent launch is
      resulting in an app crash. I tried this on the vanilla phonegap
      example app and seeing the same behavior. Wondering if someone has
      seen this before?

        Activity

        Joe Bowser added a comment -

        Can you provide more information, such as the version of Android? I need to know this if I am to try to reproduce the bug on this end.

        Simon MacDonald added a comment -

        I really can't as I only copied this from the github issues as I didn't want it to get lost. If you can't reproduce it I'd close it until someone else can provide a repo scenario.

        Brion Vibber added a comment -

        Testing with our Wikipedia app... (should be in the Android Market for free, make sure you get the one from Wikimedia Foundation not one of the unofficial apps).

        I don't get a crash, but when first restarting the app after a language change it doesn't seem to quite finish... the app never displays.

        On a second attempt, the app loads and displays as expected.

        No crashes or backtraces are visible in adb logcat output; I'm not really sure what to look for.

        Aase added a comment -

        Hi,

        I'm experience the same bug when changeing language. Om first attempt, the app, like Brion says, doesn't quite finish or seem to launch properly. The splash screen shows for a millisecond and then the app close. Om second attempt everything works fine.

        (I'm using local database if that has something to do with it).

        Hope this bug is fixed soon.


          People

          • Assignee:
            Joe Bowser
            Reporter:
            Simon MacDonald
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development