Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-14172

save-exact preferences from .npmrc should be overridden

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 1.3.0
    • Fix Version/s: None
    • Component/s: cordova-fetch
    • Labels:
      None

      Description

      When I add `save-exact=true` to my `.npmrc` and run the test suite for cordova-fetch, it will fail, because the exact 5.1.1 version will be persisted to the `package.json` instead of the expected semver range `^5.1.1`.

      `save-exact` should be disabled explicitly by default unless the related option was provided.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                OliverSalzburg Oliver Salzburg
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1h
                  1h
                  Remaining:
                  Remaining Estimate - 1h
                  1h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified