Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-14171

Unable to install scoped npm plugin from git

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: None
    • Component/s: cordova-fetch
    • Labels:
      None
    • Flags:
      Important

      Description

      When attempting to install a plugin from a git URL and the plugin is under an npm scope, the installation fails.

       

      $ cordova plugin add https://github.com/fairmanager-cordova/plugin-push.git --verbose --debug
      No scripts found for hook "before_plugin_add".
      Calling plugman.fetch on plugin "https://github.com/fairmanager-cordova/plugin-push.git"
      saving
      Running command: cmd "/s /c "C:\Users\OliverSalzburg\AppData\Local\nvs\default\npm.cmd install https://github.com/fairmanager-cordova/plugin-push.git --production --save""
      Command finished with error code 0: cmd /s /c "C:\Users\OliverSalzburg\AppData\Local\nvs\default\npm.cmd install https://github.com/fairmanager-cordova/plugin-push.git --production --save"
      {{

      { CordovaError: Failed to get absolute path to installed module}

      }

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                OliverSalzburg Oliver Salzburg
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: