Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-13952

cordova build ios Failing due to "Pods/Target Support Files" being cleared

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: cordova-ios@4.5.4
    • Fix Version/s: None
    • Component/s: cordova-ios
    • Labels:
    • Environment:

      cordova@7.1.0

      cordova-ios@4.5.4

      OS: OSx Sierra (10.12.6)

      Description

      After runnign `cordova platform add ios --nofetch` and `pod install`, the `cordova build ios --nofetch --device --release` command fails (also fails for debug builds).

      The reason it fails is because `platforms/ios/Pods/Target Support Files/` is completely empty and during the build it errors because it cannot find configs for the Pod dependencies in that folder. I have verified that the `Target Support Files` folder is not empty after adding the platform nor is it empty after running `pod install`. However, as soon as the build command runs it is empty.

      The errors are similar to these:

      Ignoring configuration file '/Users/jenkins/build/workspace/triggi-app-release/platforms/ios/cordova/build-release.xcconfig' because it could not be loaded.
      	Reason: File could not be parsed due to preprocessing errors:
          pods-release.xcconfig line 2: Unable to find included file "Pods/Target Support Files/Pods-Olisto/Pods-Olisto.release.xcconfig"User defaults from command line:
          IDEArchivePathOverride = /Users/jenkins/build/workspace/triggi-app-release/platforms/ios/Olisto.xcarchive
      
      clang: error: no such file or directory: '/Users/jenkins/build/workspace/triggi-app-release/platforms/ios/Pods/Target Support Files/GoogleToolboxForMac/GoogleToolboxForMac-dummy.m'
      clang: error: no input files
      

      The weird thing is that, after the build fails, when I run the same `pod install` command and thereafter `cordova build ios --nofetch --device --release` the build succeeds. The output from CocoaPods isn't any different. This problem started occurring about a week ago and never occurred in the months before.

      I have also verified that the plugins we use that depend on CocoaPods were not updated in the past few weeks when the error started occurring.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              TMMeijers Thomas Meijers
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: