Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-13524

Requirements check failed for JDK 1.8 or greater

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Environment:

      cordova --version 7.1.0 (npm says 5.5.1),
      cordova platform android 6.3.0
      win8,
      java sdk 9.0.1

      Description

      After using cordova build android
      I get error
      JAVA_HOME=C:\Program Files\Java\jdk-9.0.1
      Error: Requirements check failed for JDK 1.8 or greater

      is the 9.01 not good ?
      Should I install Java SE Development Kit 8u151 or Java SE Development Kit 8u152 ?

      PS also on page http://cordova.apache.org/contribute/issues.html

      Finding out versions

      You can quickly find out versions of platforms/plugins you're using by running:

      cordova platform ls

      should be replaced with cordova platform

        Attachments

          Activity

            People

            • Assignee:
              bowserj Joey Robert Bowser
              Reporter:
              GrosSacASacs Cyril Walle
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified