Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-13398

Android build failing cordova-plugin-geolocation

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      cordova-android@6.3.0 is causing a warning for cordova-plugin-geolocation plugin.

      Description

      Upgrading project to cordova-android@6.3.0 is causing warning(skipping) for cordova-plugin-geolocation because this plugin has dependency on <dependency id="cordova-plugin-compat" version="^1.0.0" /> which went deprecated from cordova-android@6.3.0.

      The solution seems to be updating plugin.xml of cordova-plugin-geolocation to following value:
      <dependency id="cordova-plugin-compat" version="1.2.0" />

      As per https://github.com/apache/cordova-plugin-compat:
      This plugin is no longer being worked on as the functionality provided by this plugin is now included in cordova-android 6.3.0. You should upgrade your application to use version 1.2.0 of this plugin. It will detect whether or not the plugin is required based on the version of cordova-android your app uses.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              stripathix Shashwat Tripathi
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: